Convert l2tpd to new packaging style
authorNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 02:58:14 +0000 (02:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 02:58:14 +0000 (02:58 +0000)
SVN-Revision: 943

openwrt/package/l2tpd/Config.in
openwrt/package/l2tpd/Makefile
openwrt/package/l2tpd/ipkg/l2tpd.control [new file with mode: 0644]
openwrt/package/l2tpd/l2tpd.control [deleted file]

index 5dd4a74addcdc187fbe766d542979c1ade757616..297bbcae08188a6f21011da84deaadae7a6dd75f 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_L2TPD
-       tristate "l2tpd"
+       tristate "l2tpd - L2TP (Layer 2 Tunneling Protocol) daemon"
        default m if CONFIG_DEVEL
        help
         A layer 2 tunneling protocol implementation.
index 4cae74e44ab534f84e77aaee780def8542923e74..ac80e0b09f4bcc809b022ab78db497f0fe73084c 100644 (file)
@@ -13,40 +13,25 @@ PKG_SOURCE:=$(PKG_NAME)_$(PKG_UPSTREAM_VERSION).orig.tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).orig
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-IPKG_L2TPD:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-IDIR_L2TPD:=$(PKG_BUILD_DIR)/ipkg/$(PKG_NAME)
-INFO_L2TPD:=$(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+include $(TOPDIR)/package/rules.mk
 
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+$(eval $(call PKG_template,L2TPD,l2tpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
 
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CC=$(TARGET_CC) \
                CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION"
+       touch $@
 
-$(IPKG_L2TPD): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_L2TPD) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(IDIR_L2TPD)/usr/sbin
-       cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_L2TPD)/usr/sbin/
-       $(STRIP) $(IDIR_L2TPD)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
+$(IPKG_L2TPD):
+       install -d -m0755 $(IDIR_L2TPD)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_L2TPD)/usr/sbin/
+       $(RSTRIP) $(IDIR_L2TPD)
        $(IPKG_BUILD) $(IDIR_L2TPD) $(PACKAGE_DIR)
 
-$(INFO_L2TPD): $(IPKG_L2TPD)
-       $(IPKG) install $(IPKG_L2TPD)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(IPKG_L2TPD)
-install: $(INFO_L2TPD)
-
-clean:
-       rm -rf $(PKG_BUILD_DIR) $(IPKG_L2TPD)
diff --git a/openwrt/package/l2tpd/ipkg/l2tpd.control b/openwrt/package/l2tpd/ipkg/l2tpd.control
new file mode 100644 (file)
index 0000000..57d60a1
--- /dev/null
@@ -0,0 +1,10 @@
+Package: l2tpd
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: A layer 2 tunneling protocol implementation.
+ l2tpd is the open source implementation of the L2TP tunneling
+ protocol (RFC2661). It does implement both LAC and LNS role 
+ in a L2TP networking architecture. The main goal of this protocol is 
+ to tunnel PPP frame trough an ip network. 
diff --git a/openwrt/package/l2tpd/l2tpd.control b/openwrt/package/l2tpd/l2tpd.control
deleted file mode 100644 (file)
index 57d60a1..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-Package: l2tpd
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: A layer 2 tunneling protocol implementation.
- l2tpd is the open source implementation of the L2TP tunneling
- protocol (RFC2661). It does implement both LAC and LNS role 
- in a L2TP networking architecture. The main goal of this protocol is 
- to tunnel PPP frame trough an ip network.