add rrdtool1 (v1.0.x) and enable it by default, disable rrdtool (v1.2.x), change...
authorNicolas Thill <nico@openwrt.org>
Thu, 8 Sep 2005 22:01:19 +0000 (22:01 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 8 Sep 2005 22:01:19 +0000 (22:01 +0000)
SVN-Revision: 1881

15 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/rrdcollect/Config.in
openwrt/package/rrdcollect/Makefile
openwrt/package/rrdcollect/ipkg/rrdcollect.control
openwrt/package/rrdtool/Config.in
openwrt/package/rrdtool/Makefile
openwrt/package/rrdtool/ipkg/librrd.control
openwrt/package/rrdtool/ipkg/rrdcgi.control
openwrt/package/rrdtool/ipkg/rrdtool.control
openwrt/package/rrdtool1/Config.in [new file with mode: 0644]
openwrt/package/rrdtool1/Makefile [new file with mode: 0644]
openwrt/package/rrdtool1/ipkg/librrd1.control [new file with mode: 0644]
openwrt/package/rrdtool1/ipkg/rrdcgi1.control [new file with mode: 0644]
openwrt/package/rrdtool1/ipkg/rrdtool1.control [new file with mode: 0644]

index c97fec291603827d48c986e1197fe27e90a1933f..905fca2defdb5ca23d5dae62926091c75964c362 100644 (file)
@@ -25,8 +25,11 @@ source "package/sablevm/Config.in"
 source "package/sablevm-classpath/Config.in"
 source "package/libffi-sable/Config.in"
 endmenu
-source "package/rrdcollect/Config.in"
+menu "rrdtool - Round-Robin Database (RRD) libraries and tools"
 source "package/rrdtool/Config.in"
+source "package/rrdtool1/Config.in"
+source "package/rrdcollect/Config.in"
+endmenu
 source "package/screen/Config.in"
 
 comment "Networking"
index e078d188006727979faa47f098fd34d95c19b75b..cdc592bdde2be016865bcaf37381dac2a9699d7d 100644 (file)
@@ -135,6 +135,7 @@ package-$(BR2_PACKAGE_ROBOCFG) += robocfg
 package-$(BR2_PACKAGE_RP_PPPOE) += rp-pppoe
 package-$(BR2_PACKAGE_RRDCOLLECT) += rrdcollect
 package-$(BR2_COMPILE_RRDTOOL) += rrdtool
+package-$(BR2_COMPILE_RRDTOOL1) += rrdtool1
 package-$(BR2_PACKAGE_RSYNC) += rsync
 package-$(BR2_PACKAGE_SABLEVM) += sablevm
 package-$(BR2_PACKAGE_SABLEVM_CLASSPATH) += sablevm-classpath
@@ -230,8 +231,14 @@ portmap-compile: tcp_wrappers-compile
 postgresql-compile: zlib-compile
 ppp-compile: linux-atm-compile
 quagga-compile: readline-compile ncurses-compile
+ifneq ($(BR2_PACKAGE_LIBRRD),)
 rrdcollect-compile: rrdtool-compile
+endif
+ifneq ($(BR2_PACKAGE_LIBRRD1),)
+rrdcollect-compile: rrdtool1-compile
+endif
 rrdtool-compile: cgilib-compile freetype-compile libart-compile libpng-compile
+rrdtool1-compile: zlib-compile
 rsync-compile: popt-compile
 samba-compile: cups-compile
 screen-compile: ncurses-compile
index e7f2919058780b5c65c7021c26c52b861d74280e..7dad23275fdc5d7faca70db23ed56473930cc5cb 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_RRDCOLLECT
        tristate "rrdcollect - Round-Robin Database (RRD) collecting daemon"
        default m if CONFIG_DEVEL
-       select BR2_PACKAGE_LIBRRD
+       depends BR2_PACKAGE_LIBRRD || BR2_PACKAGE_LIBRRD1
        help
          RRDcollect is a daemon which polls ceratin files in /proc/
          directory, gathering data and storing it inside RRDtool's
index 94dea16a30e89a88e4a1432ef092de6d34123637..b3be69a983f6a41a02165e2e765ddb309405514a 100644 (file)
@@ -14,6 +14,10 @@ PKG_CAT:=zcat
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
+ifneq ($(BR2_PACKAGE_LIBRRD),)
+RRDTOOL_LIBS:=-lart_lgpl_2 -lfreetype -lpng
+endif
+
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,RRDCOLLECT,rrdcollect,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -23,9 +27,9 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DSOCKET_COMM" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
-               LIBS="-lart_lgpl_2 -lfreetype -lpng -lz" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               LIBS="$(RRDTOOL_LIBS) -lz" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                ac_cv_func_malloc_0_nonnull=yes \
                ./configure \
@@ -48,6 +52,8 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                        $(DISABLE_LARGEFILE) \
                        --enable-shared \
                        --disable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
                        --enable-exec \
                        --without-rrdtool \
                        --with-librrd \
index e1429b63ac257e40516b35a6919d663fb9ca67f1..bdc7adb692642964631b8f86e168b9c976fa93f5 100644 (file)
@@ -1,9 +1,9 @@
 Package: rrdcollect
 Priority: optional
 Section: admin
-Maintainer: Oliver Ertl <oliver@ertl-net.net>, OpenWrt Developers <bugs@openwrt.org>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Oliver Ertl <oliver@ertl-net.net>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/rrdcollect/
-Depends: librrd
+Depends: librrd | librrd1
 Description: Round-Robin Database (RRD) collecting daemon
  RRDcollect is a daemon which polls certain files in /proc/
  directory, gathering data and storing it inside RRDtool's
index 058fe4e7134114f99a24a61d333fdf1050b637ba..f464af23e4cf5d0b547401f59057b4d8a3bef43b 100644 (file)
@@ -1,18 +1,17 @@
-menu "rrdtool - Round Robin Database (RRD) management tools and library"
-
 config BR2_COMPILE_RRDTOOL
        bool
        default no
-       depends BR2_PACKAGE_LIBRRD || BR2_PACKAGE_RRDCGI || BR2_PACKAGE_RRDTOOL
+       depends BR2_PACKAGE_LIBRRD
 
 config BR2_PACKAGE_LIBRRD
-       tristate "librrd - Round Robin Database (RRD) management library"
-#      default m if CONFIG_DEVEL
+       tristate "librrd - Round Robin Database (RRD) management library (v1.2.x)"
        default n
+       depends !BR2_COMPILE_RRDTOOL1
        select BR2_COMPILE_RRDTOOL
        select BR2_PACKAGE_LIBART
        select BR2_PACKAGE_LIBFREETYPE
        select BR2_PACKAGE_LIBPNG
+       select BR2_PACKAGE_ZLIB
        help
          RRD is the Acronym for Round Robin Database. RRD is a system to store and
          display time-series data (i.e. network bandwidth, machine-room temperature,
@@ -28,12 +27,10 @@ config BR2_PACKAGE_LIBRRD
          
 
 config BR2_PACKAGE_RRDCGI
-       tristate "rrdcgi - Round Robin Database (RRD) CGI graphing tool"
-#      default m if CONFIG_DEVEL
+       tristate "rrdcgi - Round Robin Database (RRD) CGI graphing tool (v1.2.x)"
        default n
-       select BR2_COMPILE_RRDTOOL
+       depends BR2_PACKAGE_LIBRRD
        select BR2_PACKAGE_CGILIB
-       select BR2_PACKAGE_LIBRRD
        help
          RRD is the Acronym for Round Robin Database. RRD is a system to store and
          display time-series data (i.e. network bandwidth, machine-room temperature,
@@ -50,11 +47,9 @@ config BR2_PACKAGE_RRDCGI
          
 
 config BR2_PACKAGE_RRDTOOL
-       tristate "rrdtool - Round Robin Database (RRD) management tools"
-#      default m if CONFIG_DEVEL
+       tristate "rrdtool - Round Robin Database (RRD) management tools (v1.2.x)"
        default n
-       select BR2_COMPILE_RRDTOOL
-       select BR2_PACKAGE_LIBRRD
+       depends BR2_PACKAGE_LIBRRD
        help
          RRD is the Acronym for Round Robin Database. RRD is a system to store and
          display time-series data (i.e. network bandwidth, machine-room temperature,
@@ -69,5 +64,3 @@ config BR2_PACKAGE_RRDTOOL
          This package contains command line tools used to manage RRDs.
          
 
-endmenu
-
index 2b97a530e7908bbc087997acd03f87f6348f62b7..4daedd960f448b072407ba7cfde302a4ef5ca489 100644 (file)
@@ -22,11 +22,11 @@ $(eval $(call PKG_template,RRDTOOL,rrdtool,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/freetype2 -I$(STAGING_DIR)/usr/include/libart-2.0" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/freetype2 -I$(STAGING_DIR)/usr/include/libart-2.0" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               $(TARGET_CONFIGURE_OPTS) \
                rd_cv_ieee_works=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
@@ -49,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                        --enable-shared=yes \
                        --enable-static=yes \
                        --disable-rpath \
+                       --with-gnu-ld \
                        --enable-rrdcgi \
                        --disable-mmap \
                        --disable-perl \
@@ -69,20 +70,20 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_RRDTOOL):
        install -d -m0755 $(IDIR_RRDTOOL)/usr/bin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdtool $(IDIR_RRDTOOL)/usr/bin/rrdtool
-       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdupdate $(IDIR_RRDTOOL)/usr/bin/rrdupdate
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdtool $(IDIR_RRDTOOL)/usr/bin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdupdate $(IDIR_RRDTOOL)/usr/bin/
        $(RSTRIP) $(IDIR_RRDTOOL)
        $(IPKG_BUILD) $(IDIR_RRDTOOL) $(PACKAGE_DIR)
 
 $(IPKG_RRDCGI):
        install -d -m0755 $(IDIR_RRDCGI)/usr/bin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdcgi $(IDIR_RRDCGI)/usr/bin/rrdcgi
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdcgi $(IDIR_RRDCGI)/usr/bin/
        $(RSTRIP) $(IDIR_RRDCGI)
        $(IPKG_BUILD) $(IDIR_RRDCGI) $(PACKAGE_DIR)
 
 $(IPKG_LIBRRD):
        install -d -m0755 $(IDIR_LIBRRD)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.so.* $(IDIR_LIBRRD)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.so.* $(IDIR_LIBRRD)/usr/lib/
        install -d -m0755 $(IDIR_LIBRRD)/usr/share/rrdtool/fonts
        cp -fpR $(PKG_BUILD_DIR)/src/DejaVuSansMono-Roman.ttf \
                $(IDIR_LIBRRD)/usr/share/rrdtool/fonts/
@@ -93,7 +94,8 @@ $(STAGING_DIR)/usr/lib/librrd.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/rrd.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.{a,so*} $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.a $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.so* $(STAGING_DIR)/usr/lib/
        touch $@
 
 install-dev: $(STAGING_DIR)/usr/lib/librrd.so
@@ -101,7 +103,8 @@ install-dev: $(STAGING_DIR)/usr/lib/librrd.so
 uninstall-dev:
        rm -rf \
                $(STAGING_DIR)/usr/include/rrd.h \
-               $(STAGING_DIR)/usr/lib/librrd.{a,so*} \
+               $(STAGING_DIR)/usr/lib/librrd.a \
+               $(STAGING_DIR)/usr/lib/librrd.so* \
 
 compile: install-dev
 clean: uninstall-dev
index 6ee92811f6f3e86b5b4b1dbfb813b9978aa5f0d5..7585836534b45daa3be60bf931878423b3fff0b1 100644 (file)
@@ -1,7 +1,7 @@
 Package: librrd
 Priority: optional
 Section: libs
-Maintainer: Oliver Ertl <oliver@ertl-net.net>, OpenWrt Developers <bugs@openwrt.org>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Oliver Ertl <oliver@ertl-net.net>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/rrdtool/
 Depends: libart, libfreetype, libpng, zlib
 Description: Round Robin Database (RRD) management library. 
index b73f4808a0c0097c4ea1762e221f1d6518472710..d5079fcd0d12f467bd1a0e336098a2e7e1e99ea3 100644 (file)
@@ -1,7 +1,7 @@
 Package: rrdcgi
 Priority: optional
 Section: web
-Maintainer: Oliver Ertl <oliver@ertl-net.net>, OpenWrt Developers <bugs@openwrt.org>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Oliver Ertl <oliver@ertl-net.net>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/rrdtool/
 Depends: cgilib, librrd
 Description: Round Robin Database (RRD) CGI graphing tool. 
index 6b4d8e8b57b242a8a42093675e231ae9a555725d..5da8e7a0e7abff7de6a4655a0589848f0a8c612e 100644 (file)
@@ -1,7 +1,7 @@
 Package: rrdtool
 Priority: optional
 Section: admin
-Maintainer: Oliver Ertl <oliver@ertl-net.net>, OpenWrt Developers <bugs@openwrt.org>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Oliver Ertl <oliver@ertl-net.net>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/rrdtool/
 Depends: librrd
 Description: Round Robin Database (RRD) management tools. 
diff --git a/openwrt/package/rrdtool1/Config.in b/openwrt/package/rrdtool1/Config.in
new file mode 100644 (file)
index 0000000..556708b
--- /dev/null
@@ -0,0 +1,73 @@
+config BR2_COMPILE_RRDTOOL1
+       bool
+       default no
+       depends BR2_PACKAGE_LIBRRD1
+
+config BR2_PACKAGE_LIBRRD1
+       tristate "librrd1 - Round Robin Database (RRD) management library (v1.0.x)"
+       default m if CONFIG_DEVEL
+       depends !BR2_COMPILE_RRDTOOL
+       select BR2_COMPILE_RRDTOOL1
+       select BR2_PACKAGE_ZLIB
+       help
+         RRD is the Acronym for Round Robin Database. RRD is a system to store and
+         display time-series data (i.e. network bandwidth, machine-room temperature,
+         server load average). It stores the data in a very compact way that will
+         not expand over time, and it presents useful graphs by processing the data
+         to enforce a certain data density. It can be used either via simple wrapper
+         scripts (from shell or Perl) or via frontends that poll network devices and
+         put friendly user interface on it.
+         
+         http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
+         
+         This package contains command line tools used to manage RRDs.
+         
+         This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
+         librrd.so. The library is much smaller compared to the 1.2.x version with 
+         separate dynamic linked libraries.
+         
+
+config BR2_PACKAGE_RRDCGI1
+       tristate "rrdcgi1 - Round Robin Database (RRD) CGI graphing tool (v1.0.x)"
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_LIBRRD1
+       help
+         RRD is the Acronym for Round Robin Database. RRD is a system to store and
+         display time-series data (i.e. network bandwidth, machine-room temperature,
+         server load average). It stores the data in a very compact way that will
+         not expand over time, and it presents useful graphs by processing the data
+         to enforce a certain data density. It can be used either via simple wrapper
+         scripts (from shell or Perl) or via frontends that poll network devices and
+         put friendly user interface on it.
+         
+         http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
+         
+         This package contains the rrdcgi tool used to create web pages containing 
+         RRD graphs based on templates.
+         
+         This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
+         librrd.so. The library is much smaller compared to the 1.2.x version with 
+         separate dynamic linked libraries.
+         
+
+config BR2_PACKAGE_RRDTOOL1
+       tristate "rrdtool1 - Round Robin Database (RRD) management tools (v1.0.x)"
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_LIBRRD1
+       help
+         RRD is the Acronym for Round Robin Database. RRD is a system to store and
+         display time-series data (i.e. network bandwidth, machine-room temperature,
+         server load average). It stores the data in a very compact way that will
+         not expand over time, and it presents useful graphs by processing the data
+         to enforce a certain data density. It can be used either via simple wrapper
+         scripts (from shell or Perl) or via frontends that poll network devices and
+         put friendly user interface on it.
+         
+         http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
+         
+         This package contains command line tools used to manage RRDs.
+         
+         This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
+         librrd.so. The library is much smaller compared to the 1.2.x version with 
+         separate dynamic linked libraries.
+
diff --git a/openwrt/package/rrdtool1/Makefile b/openwrt/package/rrdtool1/Makefile
new file mode 100644 (file)
index 0000000..7df6210
--- /dev/null
@@ -0,0 +1,105 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rrdtool1
+PKG_VERSION:=1.0.50
+PKG_RELEASE:=1
+PKG_MD5SUM:=c466e2e7df95fa8e318e46437da87686
+
+PKG_SOURCE_URL:=http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/rrdtool-1.0.x
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/rrdtool-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBRRD1,librrd1,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,RRDCGI1,rrdcgi1,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,RRDTOOL1,rrdtool1,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{status,cache} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ac_cv_path_PERL=no \
+               rd_cv_ieee_works=yes \
+               shrext_cmds=".so" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared=yes \
+                       --enable-static=yes \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --enable-local-zlib \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               shrext_cmds=".so" \
+               all install
+       touch $@
+
+$(IPKG_RRDTOOL1):
+       install -d -m0755 $(IDIR_RRDTOOL1)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdtool $(IDIR_RRDTOOL1)/usr/bin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdupdate $(IDIR_RRDTOOL1)/usr/bin/
+       $(RSTRIP) $(IDIR_RRDTOOL1)
+       $(IPKG_BUILD) $(IDIR_RRDTOOL1) $(PACKAGE_DIR)
+
+$(IPKG_RRDCGI1):
+       install -d -m0755 $(IDIR_RRDCGI1)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/rrdcgi $(IDIR_RRDCGI1)/usr/bin/
+       $(RSTRIP) $(IDIR_RRDCGI1)
+       $(IPKG_BUILD) $(IDIR_RRDCGI1) $(PACKAGE_DIR)
+
+$(IPKG_LIBRRD1):
+       install -d -m0755 $(IDIR_LIBRRD1)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.so.* $(IDIR_LIBRRD1)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBRRD1)
+       $(IPKG_BUILD) $(IDIR_LIBRRD1) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/librrd.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/rrd.h $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.a $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/librrd.so* $(STAGING_DIR)/usr/lib/
+       touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/librrd.so
+
+uninstall-dev:
+       rm -rf \
+               $(STAGING_DIR)/usr/include/rrd.h \
+               $(STAGING_DIR)/usr/lib/librrd.a \
+               $(STAGING_DIR)/usr/lib/librrd.so* \
+
+compile: install-dev
+clean: uninstall-dev
diff --git a/openwrt/package/rrdtool1/ipkg/librrd1.control b/openwrt/package/rrdtool1/ipkg/librrd1.control
new file mode 100644 (file)
index 0000000..9903904
--- /dev/null
@@ -0,0 +1,20 @@
+Package: librrd1
+Priority: optional
+Section: libs
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Christian Magnusson <mag@mag.cx>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/rrdtool1/
+Depends: zlib
+Description: Round Robin Database (RRD) management library. 
+ RRD is the Acronym for Round Robin Database. RRD is a system to store and
+ display time-series data (i.e. network bandwidth, machine-room temperature,
+ server load average). It stores the data in a very compact way that will
+ not expand over time, and it presents useful graphs by processing the data
+ to enforce a certain data density. It can be used either via simple wrapper
+ scripts (from shell or Perl) or via frontends that poll network devices and
+ put friendly user interface on it.
+ .
+ This package contains the shared library used to manage RRDs.
+ .
+ This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
+ librrd.so. The library is much smaller compared to the 1.2.x version with 
+ separate dynamic linked libraries.
diff --git a/openwrt/package/rrdtool1/ipkg/rrdcgi1.control b/openwrt/package/rrdtool1/ipkg/rrdcgi1.control
new file mode 100644 (file)
index 0000000..6fccaa7
--- /dev/null
@@ -0,0 +1,21 @@
+Package: rrdcgi1
+Priority: optional
+Section: web
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Christian Magnusson <mag@mag.cx>
+Source: http://home.mag.cx/openwrt/package/rrdtool1/
+Depends: librrd1
+Description: Round Robin Database (RRD) CGI graphing tool. 
+ RRD is the Acronym for Round Robin Database. RRD is a system to store and
+ display time-series data (i.e. network bandwidth, machine-room temperature,
+ server load average). It stores the data in a very compact way that will
+ not expand over time, and it presents useful graphs by processing the data
+ to enforce a certain data density. It can be used either via simple wrapper
+ scripts (from shell or Perl) or via frontends that poll network devices and
+ put friendly user interface on it.
+ .
+ This package contains the rrdcgi tool used to create web pages containing 
+ RRD graphs based on templates.
+ .
+ This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
+ librrd.so. The library is much smaller compared to the 1.2.x version with 
+ separate dynamic linked libraries.
diff --git a/openwrt/package/rrdtool1/ipkg/rrdtool1.control b/openwrt/package/rrdtool1/ipkg/rrdtool1.control
new file mode 100644 (file)
index 0000000..7363bcc
--- /dev/null
@@ -0,0 +1,20 @@
+Package: rrdtool1
+Priority: optional
+Section: admin
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Christian Magnusson <mag@mag.cx>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/rrdtool1/
+Depends: librrd1
+Description: Round Robin Database (RRD) management tools. 
+ RRD is the Acronym for Round Robin Database. RRD is a system to store and
+ display time-series data (i.e. network bandwidth, machine-room temperature,
+ server load average). It stores the data in a very compact way that will
+ not expand over time, and it presents useful graphs by processing the data
+ to enforce a certain data density. It can be used either via simple wrapper
+ scripts (from shell or Perl) or via frontends that poll network devices and
+ put friendly user interface on it.
+ .
+ This package contains command line tools used to manage RRDs.
+ .
+ This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
+ librrd.so. The library is much smaller compared to the 1.2.x version with 
+ separate dynamic linked libraries.