bluez stuff, thx Markus Becker
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Thu, 14 Jul 2005 11:45:22 +0000 (11:45 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Thu, 14 Jul 2005 11:45:22 +0000 (11:45 +0000)
SVN-Revision: 1434

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/bluez-libs/Config.in [new file with mode: 0644]
openwrt/package/bluez-libs/Makefile [new file with mode: 0644]
openwrt/package/bluez-libs/ipkg/bluez-libs.control [new file with mode: 0644]
openwrt/package/bluez-utils/Config.in [new file with mode: 0644]
openwrt/package/bluez-utils/Makefile [new file with mode: 0644]
openwrt/package/bluez-utils/ipkg/bluez-utils.control [new file with mode: 0644]

index 89eef84bdf77928d3facfe87be42249e75b14cdd..e3662b7762c3fd2bb2607f56142b73c9399ab7d3 100644 (file)
@@ -151,6 +151,10 @@ comment "Kernel related ---"
 source "package/fuse/Config.in"  # kmod-fuse
 source "package/shfs/Config.in"  # kmod-shfs
 
+comment "Bluetooth related"
+source "package/bluez-libs/Config.in"
+source "package/bluez-utils/Config.in"
+
 comment "Extra stuff"
 source "package/sdk/Config.in"
 
index e7fb53568f91dc9e0f302c57a92c237a347f14e2..f1687c4e7818ed1d1003565c4b075206a8121ac8 100644 (file)
@@ -9,6 +9,8 @@ package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
 package-$(BR2_PACKAGE_ASTERISK) += asterisk
 package-$(BR2_PACKAGE_ASTERISK) += atftp
 package-$(BR2_PACKAGE_BIND) += bind
+package-$(BR2_PACKAGE_BLUEZ_LIBS) += bluez-libs
+package-$(BR2_PACKAGE_BLUEZ_UTILS) += bluez-utils
 package-$(BR2_PACKAGE_BRIDGE) += bridge
 package-$(BR2_PACKAGE_BUSYBOX) += busybox
 package-$(BR2_PACKAGE_BWM) += bwm
diff --git a/openwrt/package/bluez-libs/Config.in b/openwrt/package/bluez-libs/Config.in
new file mode 100644 (file)
index 0000000..2079771
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_BLUEZ_LIBS
+       tristate "bluez-libs"
+       default m if CONFIG_DEVEL
+       help
+         Bluez libs. 
+         
+         http://bluez.org
+         
diff --git a/openwrt/package/bluez-libs/Makefile b/openwrt/package/bluez-libs/Makefile
new file mode 100644 (file)
index 0000000..6a65590
--- /dev/null
@@ -0,0 +1,87 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bluez-libs
+PKG_VERSION:=2.17
+PKG_RELEASE:=2
+PKG_MD5SUM:=7b81dc86a48b89600eee235c6c940c51
+
+PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,BLUEZ_LIBS,bluez-libs,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.source: $(DL_DIR)/$(PKG_SOURCE)
+       zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(BLUEZLIBS_DIR)/.source
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+               sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --enable-static \
+                 --disable-rpath \
+                 --without-x \
+                 --with-png=$(STAGING_DIR)/usr \
+       )
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_BLUEZ_LIBS):
+       install -d -m0755 $(IDIR_BLUEZ_LIBS)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.so.* $(IDIR_BLUEZ_LIBS)/usr/lib/
+       $(RSTRIP) $(IDIR_BLUEZ_LIBS)
+       $(IPKG_BUILD) $(IDIR_BLUEZ_LIBS) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libbluetooth.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/include/bluetooth
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/bluetooth/*.h $(STAGING_DIR)/usr/include/bluetooth
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fp $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.{a,so*} $(STAGING_DIR)/usr/lib/
+
+install-dev: $(STAGING_DIR)/usr/lib/libbluetooth.so
+
+uninstall-dev:
+       rm -rf $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*}
+
+compile: install-dev
+clean: uninstall-dev
diff --git a/openwrt/package/bluez-libs/ipkg/bluez-libs.control b/openwrt/package/bluez-libs/ipkg/bluez-libs.control
new file mode 100644 (file)
index 0000000..e7d0974
--- /dev/null
@@ -0,0 +1,7 @@
+Package: bluez-libs
+Priority: optional
+Section: net
+Maintainer: Markus Becker <mab@comnets.uni-bremen.de>
+Source: http://bluez.org
+Description: Bluez libs
+Depends: kmod-bluetooth
diff --git a/openwrt/package/bluez-utils/Config.in b/openwrt/package/bluez-utils/Config.in
new file mode 100644 (file)
index 0000000..039ff5d
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_BLUEZ_UTILS
+       tristate "bluez-utils"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_GLIB
+       select BR2_PACKAGE_BLUEZ_LIBS
+       help
+         Bluez utils. 
+         
+         http://bluez.org
+         
+         Depends: libpthread, bluez-libs
diff --git a/openwrt/package/bluez-utils/Makefile b/openwrt/package/bluez-utils/Makefile
new file mode 100644 (file)
index 0000000..40ab279
--- /dev/null
@@ -0,0 +1,83 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bluez-utils
+PKG_VERSION:=2.17
+PKG_RELEASE:=2
+PKG_MD5SUM:=42be19b0029a83824358baa0106da947
+
+PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,BLUEZ_UTILS,bluez-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+
+$(PKG_BUILD_DIR)/.source: $(DL_DIR)/$(PKG_SOURCE)
+       zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(BLUEZLIBS_DIR)/.source
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+               sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --enable-static \
+                 --disable-rpath \
+                 --without-x \
+                 --with-bluez=$(STAGING_DIR)/usr/include \
+                 --with-usb=$(STAGING_DIR)/usr/include \
+                 --without-glib \
+       )
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_BLUEZ_UTILS):
+       install -d -m0755 $(IDIR_BLUEZ_UTILS)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/* $(IDIR_BLUEZ_UTILS)/usr/bin/
+       install -d -m0755 $(IDIR_BLUEZ_UTILS)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/* $(IDIR_BLUEZ_UTILS)/usr/sbin/
+       install -d -m0755 $(IDIR_BLUEZ_UTILS)/etc/bluetooth
+       cp -fp $(PKG_INSTALL_DIR)/../hcid/hcid.conf* $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
+       cp -fp $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf* $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
+
+       $(RSTRIP) $(IDIR_BLUEZ_UTILS)
+       $(IPKG_BUILD) $(IDIR_BLUEZ_UTILS) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/bluez-utils/ipkg/bluez-utils.control b/openwrt/package/bluez-utils/ipkg/bluez-utils.control
new file mode 100644 (file)
index 0000000..7592cbf
--- /dev/null
@@ -0,0 +1,7 @@
+Package: bluez-utils
+Priority: optional
+Section: net
+Maintainer: Markus Becker <mab@comnets.uni-bremen.de>
+Source: http://bluez.org
+Description: Bluez libs
+Depends: kmod-bluetooth, bluez-libs