wolfssl: add lighty support, skip crypttests
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Mon, 7 Dec 2020 02:43:47 +0000 (23:43 -0300)
committerPetr Štetiar <ynezz@true.cz>
Fri, 11 Dec 2020 12:48:24 +0000 (13:48 +0100)
Tnis adds the --enable-lighty option to configure, enabling the minimum
API needed to run lighttpd, in the packages feed.  Size increase is
about 120 bytes for arm_cortex-a9_vfpv3-d16.

While at it, speed up build by disabling crypt bench/test.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
package/libs/wolfssl/Makefile

index dc8ca2b262708ad44359572a1baa57c08a49aefc..4b891d634a18453a18d492ff4c5cda51ffdab07c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wolfssl
 PKG_VERSION:=4.5.0-stable
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
@@ -61,9 +61,11 @@ TARGET_LDFLAGS += -flto
 
 # --enable-stunnel needed for OpenSSL API compatibility bits
 CONFIGURE_ARGS += \
+       --enable-lighty \
        --enable-opensslextra \
        --enable-sni \
        --enable-stunnel \
+       --disable-crypttests \
        --disable-examples \
        --disable-jobserver \
        --$(if $(CONFIG_IPV6),enable,disable)-ipv6 \