Add fastcgi subpackage (Thanks aorlinsk for the help)
authorNicolas Thill <nico@openwrt.org>
Mon, 4 Jul 2005 12:11:08 +0000 (12:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 4 Jul 2005 12:11:08 +0000 (12:11 +0000)
SVN-Revision: 1331

openwrt/package/lighttpd/Config.in
openwrt/package/lighttpd/Makefile
openwrt/package/lighttpd/ipkg/lighttpd-mod-fastcgi.control [new file with mode: 0644]

index fd423358a449b0bb60fd472b19e05e2229456b76..f1b7f1e2efc4c2510bcd8efe1fa2aeef1d38cd80 100644 (file)
@@ -32,6 +32,12 @@ config BR2_PACKAGE_LIGHTTPD_MOD_CGI
        tristate 
        default m if CONFIG_DEVEL
 
+config BR2_PACKAGE_LIGHTTPD_MOD_FASTCGI
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "...-mod-fastcgi - FastCGI module"
+       tristate 
+       default m if CONFIG_DEVEL
+
 config BR2_PACKAGE_LIGHTTPD_MOD_PROXY
        depends BR2_PACKAGE_LIGHTTPD
        prompt "...-mod-proxy - Proxy module"
index 38aaa855ff01045eedfec46a82255e5efb2e04a0..df6a7df35339a013a13e7544c5a779b0f39ab9cc 100644 (file)
@@ -30,6 +30,7 @@ $(eval $(call PKG_template,LIGHTTPD,lighttpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_FASTCGI,lighttpd-mod-fastcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_PROXY,lighttpd-mod-proxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_REDIRECT,lighttpd-mod-redirect,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_REWRITE,lighttpd-mod-rewrite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -41,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_V
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_FASTCGI,fastcgi))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_PROXY,proxy))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_REDIRECT,redirect))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_REWRITE,rewrite))
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-fastcgi.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-fastcgi.control
new file mode 100644 (file)
index 0000000..e653e95
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-fastcgi
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Anael Orlinski <anael.orlinski@gmail.com>, Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/lighttpd/
+Description: FASTCGI module for lighttpd
+Depends: lighttpd