fix bridge build and description, add default configure command to rules.mk, use...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 21 Apr 2006 09:55:30 +0000 (09:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 21 Apr 2006 09:55:30 +0000 (09:55 +0000)
SVN-Revision: 3690

openwrt/package/bridge/Makefile
openwrt/package/rules.mk

index be52b2a9754229b54474944b64662e07b92df1f9..18ea1dd2caf92346180b0246e0e4dde0e27aafdf 100644 (file)
@@ -19,36 +19,18 @@ SECTION:=base
 CATEGORY:=Network
 DEFAULT:=y
 TITLE:=Ethernet bridging configuration utility
-DESCRIPTION:=Manage ethernet bridging; a way to connect networks together to\\\
+DESCRIPTION:=Ethernet bridging configuration utility\\\
+Manage ethernet bridging; a way to connect networks together to\\\
 form a larger network.
 URL:=http://bridge.sourceforge.net/
 endef
 
 define Build/Configure
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/var \
-               --mandir=/usr/man \
-               --infodir=/usr/info \
-               $(DISABLE_NLS) \
-               --with-linux-headers=$(LINUX_DIR)
+$(call Build/Configure/Default,--with-linux-headers=$(LINUX_DIR))
 endef
 
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)
-       touch $@
 endef
 
 define Package/busybox/install
index 230b9669bdc42cd1621bd166323a081087aea2c1..4faf9ffcd3663ff9ee1ad6d06ac3feb2165bb744 100644 (file)
@@ -81,13 +81,13 @@ IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
 IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
 INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-ifneq ($(PACKAGE_$(1)),)
+ifneq ($(CONFIG_PACKAGE_$(1)),)
 COMPILE_$(1):=1
 endif
 ifneq ($(DEVELOPER),)
 COMPILE_$(1):=1
 endif
-ifeq ($(PACKAGE_$(1)),y)
+ifeq ($(CONFIG_PACKAGE_$(1)),y)
 install-targets: $$(INFO_$(1))
 endif
 
@@ -188,10 +188,29 @@ endef
 
 define Build/Configure/Default
 # TODO: add configurable default command
+       (cd $(PKG_BUILD_DIR); \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               $(DISABLE_NLS) \
+               $(1); \
+       )
 endef
 
 define Build/Configure
-$(call Build/Configure/Default)
 endef
 
 define Build/Compile/Default