arm-trusted-firmware-mvebu: bump espressobin boards to CPU_1000_DDR_800
authorAndre Heider <a.heider@gmail.com>
Sun, 17 Jan 2021 07:38:53 +0000 (08:38 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Jan 2021 13:46:32 +0000 (14:46 +0100)
The cpufreq issue has been identified and a fix is in the process of beeing
upstreamed [0].

Bump the boards to the default 1000MHz so they can run at that frequency
once the fix is merged. Until then the boards are stuck at 800MHz (just
claiming to run 1000Hz, which is a lie).

[0] https://lore.kernel.org/linux-arm-kernel/20210114124032.12765-1-pali@kernel.org/

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/arm-trusted-firmware-mvebu/Makefile

index 55600260bf28c013ad3c63e4b7606b8d55ade5a6..a72fd53c75e6bda833c81b8aafaa53399fe74394 100644 (file)
@@ -32,7 +32,7 @@ define Trusted-Firmware-A/espressobin-512mb
   BUILD_DEVICES:=globalscale_espressobin
   UBOOT:=espressobin
   DDR_TOPOLOGY:=0
-  CLOCKSPRESET:=CPU_800_DDR_800
+  CLOCKSPRESET:=CPU_1000_DDR_800
   PLAT:=a3700
 endef
 
@@ -42,7 +42,7 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-1cs
   BUILD_DEVICES:=globalscale_espressobin
   UBOOT:=espressobin
   DDR_TOPOLOGY:=4
-  CLOCKSPRESET:=CPU_800_DDR_800
+  CLOCKSPRESET:=CPU_1000_DDR_800
   PLAT:=a3700
 endef
 
@@ -52,7 +52,7 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs
   BUILD_DEVICES:=globalscale_espressobin
   UBOOT:=espressobin
   DDR_TOPOLOGY:=2
-  CLOCKSPRESET:=CPU_800_DDR_800
+  CLOCKSPRESET:=CPU_1000_DDR_800
   PLAT:=a3700
 endef
 
@@ -62,7 +62,7 @@ define Trusted-Firmware-A/espressobin-v3-v5-2gb
   BUILD_DEVICES:=globalscale_espressobin
   UBOOT:=espressobin
   DDR_TOPOLOGY:=7
-  CLOCKSPRESET:=CPU_800_DDR_800
+  CLOCKSPRESET:=CPU_1000_DDR_800
   PLAT:=a3700
 endef
 
@@ -72,7 +72,7 @@ define Trusted-Firmware-A/espressobin-v7-1gb
   BUILD_DEVICES:=globalscale_espressobin-v7
   UBOOT:=espressobin
   DDR_TOPOLOGY:=5
-  CLOCKSPRESET:=CPU_800_DDR_800
+  CLOCKSPRESET:=CPU_1000_DDR_800
   PLAT:=a3700
 endef
 
@@ -82,7 +82,7 @@ define Trusted-Firmware-A/espressobin-v7-2gb
   BUILD_DEVICES:=globalscale_espressobin-v7
   UBOOT:=espressobin
   DDR_TOPOLOGY:=6
-  CLOCKSPRESET:=CPU_800_DDR_800
+  CLOCKSPRESET:=CPU_1000_DDR_800
   PLAT:=a3700
 endef