change handling of the Build/Clean template
authorFelix Fietkau <nbd@openwrt.org>
Sun, 11 Jun 2006 00:34:11 +0000 (00:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 11 Jun 2006 00:34:11 +0000 (00:34 +0000)
SVN-Revision: 3930

openwrt/package/rules.mk

index d44cd986a497487e0f4c426fe8bc8b040a2e7564..77a6595e82f4ba7fcca70375808d589f8e4c94e8 100644 (file)
@@ -257,10 +257,6 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
-define Build/Clean
-       $(MAKE) clean
-endef
-
 ifneq ($(DUMP),)
   dumpinfo: FORCE
        @$(DUMPINFO)
@@ -282,5 +278,6 @@ else
   clean-targets:
   clean: FORCE
        @$(MAKE) clean-targets
+       $(call Build/Clean)
        rm -rf $(PKG_BUILD_DIR)
 endif