add atftp, bind and dhcp, not perfect, but first step
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Fri, 8 Jul 2005 00:58:53 +0000 (00:58 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Fri, 8 Jul 2005 00:58:53 +0000 (00:58 +0000)
SVN-Revision: 1375

13 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/atftp/Config.in [new file with mode: 0644]
openwrt/package/atftp/Makefile [new file with mode: 0644]
openwrt/package/atftp/ipkg/atftp.control [new file with mode: 0644]
openwrt/package/atftp/ipkg/atftpd.control [new file with mode: 0644]
openwrt/package/bind/Config.in [new file with mode: 0644]
openwrt/package/bind/Makefile [new file with mode: 0644]
openwrt/package/bind/ipkg/bind.control [new file with mode: 0644]
openwrt/package/dhcp/Config.in [new file with mode: 0644]
openwrt/package/dhcp/Makefile [new file with mode: 0644]
openwrt/package/dhcp/ipkg/dhcp.control [new file with mode: 0644]
openwrt/package/libdb/Makefile

index 85936c970adce36c84724d97f89e423f85611133..3fa85f593088cb25bb7e7c79ab372a764c0401fc 100644 (file)
@@ -30,10 +30,13 @@ source "package/aiccu/Config.in"
 source "package/arptables/Config.in"
 source "package/arpwatch/Config.in"
 source "package/asterisk/Config.in"
+source "package/atftp/Config.in"
+source "package/bind/Config.in"
 source "package/bwm/Config.in"
 source "package/chillispot/Config.in"
 source "package/cifsmount/Config.in"
 source "package/cups/Config.in"
+source "package/dhcp/Config.in"
 source "package/dhcp-forwarder/Config.in"
 source "package/dropbear/Config.in"
 source "package/dsniff/Config.in"
index 4c743b9bfd44cf232f947f5efceda919ebc3856b..ef7673b73793f6ab8bf8b9a8101eaf1c39bd25a7 100644 (file)
@@ -7,6 +7,8 @@ package-$(BR2_PACKAGE_AICCU) += aiccu
 package-$(BR2_PACKAGE_ARPTABLES) += arptables
 package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
 package-$(BR2_PACKAGE_ASTERISK) += asterisk
+package-$(BR2_PACKAGE_ASTERISK) += atftp
+package-$(BR2_PACKAGE_BIND) += bind
 package-$(BR2_PACKAGE_BRIDGE) += bridge
 package-$(BR2_PACKAGE_BUSYBOX) += busybox
 package-$(BR2_PACKAGE_BWM) += bwm
@@ -14,6 +16,7 @@ package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
 package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
 package-$(BR2_PACKAGE_CUPS) += cups
 package-$(BR2_PACKAGE_CYRUS_SASL) += cyrus-sasl
+package-$(BR2_PACKAGE_DHCP) += dhcp
 package-$(BR2_PACKAGE_DHCP_FORWARDER) += dhcp-forwarder
 package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
 package-$(BR2_PACKAGE_DROPBEAR) += dropbear
@@ -143,6 +146,7 @@ compile: $(patsubst %,%-compile,$(package-y) $(package-m))
 install: $(patsubst %,%-install,$(package-y))
 
 arpwatch-compile: libpcap-compile
+bind-compile: openssl-compile
 cyrus-sasl-compile: openssl-compile
 dropbear-compile: zlib-compile
 dsniff-compile: libnids-compile openssl-compile libgdbm-compile
diff --git a/openwrt/package/atftp/Config.in b/openwrt/package/atftp/Config.in
new file mode 100644 (file)
index 0000000..43ef082
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_ATFTP
+       tristate "atftp"
+       default m if CONFIG_DEVEL
+       help
+       tftp client
+
+config BR2_PACKAGE_ATFTPD
+       tristate "atftpd"
+       default m if CONFIG_DEVEL
+       help
+       tftp server 
diff --git a/openwrt/package/atftp/Makefile b/openwrt/package/atftp/Makefile
new file mode 100644 (file)
index 0000000..3acd841
--- /dev/null
@@ -0,0 +1,70 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=atftp
+PKG_VERSION:=0.7
+PKG_RELEASE:=1
+PKG_MD5SUM:=3b27365772d918050b2251d98a9c7c82
+
+PKG_SOURCE_URL:=ftp://ftp.mamalinux.com/pub/atftp/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,ATFTP,atftp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,ATFTPD,atftpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               DESTDIR=$(PKG_INSTALL_DIR) \
+               all install
+       touch $@
+
+$(IPKG_ATFTP):
+       install -d -m0755 $(IDIR_ATFTP)/usr/bin
+       cp -fpR $(PKG_BUILD_DIR)/atftp $(IDIR_ATFTP)/usr/bin
+       $(RSTRIP) $(IDIR_ATFTP)
+       $(IPKG_BUILD) $(IDIR_ATFTP) $(PACKAGE_DIR)
+
+$(IPKG_ATFTPD):
+       install -d -m0755 $(IDIR_ATFTPD)/usr/sbin
+       cp -fpR $(PKG_BUILD_DIR)/atftpd $(IDIR_ATFTPD)/usr/sbin
+       $(RSTRIP) $(IDIR_ATFTPD)
+       $(IPKG_BUILD) $(IDIR_ATFTPD) $(PACKAGE_DIR)
diff --git a/openwrt/package/atftp/ipkg/atftp.control b/openwrt/package/atftp/ipkg/atftp.control
new file mode 100644 (file)
index 0000000..6698662
--- /dev/null
@@ -0,0 +1,6 @@
+Package: atftp
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers <bugs@openwrt.org>
+Source:  http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/atftp/
+Description: tftp client
diff --git a/openwrt/package/atftp/ipkg/atftpd.control b/openwrt/package/atftp/ipkg/atftpd.control
new file mode 100644 (file)
index 0000000..db9a66d
--- /dev/null
@@ -0,0 +1,6 @@
+Package: atftpd
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers <bugs@openwrt.org>
+Source:  http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/atftp/
+Description: tftp server
diff --git a/openwrt/package/bind/Config.in b/openwrt/package/bind/Config.in
new file mode 100644 (file)
index 0000000..a820670
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_BIND
+       tristate "bind - popular dns server"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBOPENSSL
+       help
+         DNS server implementation
+         
+         http://www.isc.org/
+         
+         Depends: openssl
diff --git a/openwrt/package/bind/Makefile b/openwrt/package/bind/Makefile
new file mode 100644 (file)
index 0000000..d0bfe34
--- /dev/null
@@ -0,0 +1,98 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bind
+PKG_VERSION:=9.3.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=9ff3204eea27184ea0722f37e43fc95d
+
+PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/bind9/9.3.1/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,BIND,bind,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               ./configure \
+                 --target=$(GNU_HOST_NAME) \
+                 --host=$(GNU_HOST_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 --without-openssl \
+                 --without-ipv6 \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+       );
+       
+       $(MAKE) -C $(PKG_BUILD_DIR)/lib/isc 
+       $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns
+       $(MAKE) -C $(PKG_BUILD_DIR)/lib/isc clean
+       cp $(PKG_BUILD_DIR)/lib/dns/gen $(PKG_BUILD_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns clean
+       cp $(PKG_BUILD_DIR)/gen $(PKG_BUILD_DIR)/lib/dns/gen
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(strip $(TARGET_CFLAGS))" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --enable-static \
+                 --enable-ipv6 \
+                 --with-randomdev=/dev/random \
+                 --disable-threads \
+                 --with-openssl=$(STAGING_DIR)/usr/ \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_BIND):
+       install -d -m0755 $(IDIR_BIND)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/named $(IDIR_BIND)/usr/sbin/
+       $(RSTRIP) $(IDIR_BIND)
+       $(IPKG_BUILD) $(IDIR_BIND) $(PACKAGE_DIR)
diff --git a/openwrt/package/bind/ipkg/bind.control b/openwrt/package/bind/ipkg/bind.control
new file mode 100644 (file)
index 0000000..89daea5
--- /dev/null
@@ -0,0 +1,7 @@
+Package: bind
+Priority: optional
+Section: net
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Source: buildroot internal
+Description: popular dns server
+Depends: libopenssl
diff --git a/openwrt/package/dhcp/Config.in b/openwrt/package/dhcp/Config.in
new file mode 100644 (file)
index 0000000..d1b0530
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_DHCP
+       tristate "dhcp"
+       default m if CONFIG_DEVEL
+       help
+       dhcp server
+
+       http://www.isc.org
diff --git a/openwrt/package/dhcp/Makefile b/openwrt/package/dhcp/Makefile
new file mode 100644 (file)
index 0000000..70a72c5
--- /dev/null
@@ -0,0 +1,44 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dhcp
+PKG_VERSION:=3.0.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=04800a111521e7442749b2ce883f962b
+
+PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,DHCP,dhcp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_DHCP):
+       install -d -m0755 $(IDIR_DHCP)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(IDIR_DHCP)/usr/sbin
+       $(RSTRIP) $(IDIR_DHCP)
+       $(IPKG_BUILD) $(IDIR_DHCP) $(PACKAGE_DIR)
diff --git a/openwrt/package/dhcp/ipkg/dhcp.control b/openwrt/package/dhcp/ipkg/dhcp.control
new file mode 100644 (file)
index 0000000..d6c110a
--- /dev/null
@@ -0,0 +1,6 @@
+Package: dhcp
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers <bugs@openwrt.org>
+Source:  http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/dhcp/
+Description: isc dhcp server
index 3e26e6194cf8cddbfd403bee12660faab7173795..a6da8d8dbd57c514b1fc5dcc2733e6956469c4e4 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libdb
-PKG_VERSION:=4.3.28
-PKG_RELEASE:=0
-PKG_MD5SUM:=e27759537db6054b31d8cb3e99ba6fbb
+PKG_VERSION:=4.2.52
+PKG_RELEASE:=1
+PKG_MD5SUM:=x
 
 PKG_SOURCE_URL:=ftp://ftp.sleepycat.com/releases/ \
        http://downloads.sleepycat.com/
@@ -48,15 +48,16 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                --enable-shared \
                --enable-static \
                --disable-java \
-               --disable-cxx \
+               --enable-cxx \
+               --disable-posixmutexes \
+               --enable-uimutexes \
                --disable-tcl \
                --disable-rpc \
-               --disable-compat185 \
-               --disable-debug \
-               --disable-statistics \
-               --disable-replication \
-               --disable-cryptography \
-               --enable-smallbuild \
+               --enable-compat185 \
+               --enable-debug \
+               --enable-statistics \
+               --enable-replication \
+               --enable-cryptography \
        );
        touch $@