build: fix bpf toolchain dependency for qosify
authorFelix Fietkau <nbd@nbd.name>
Mon, 1 Nov 2021 17:40:03 +0000 (18:40 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 1 Nov 2021 17:41:20 +0000 (18:41 +0100)
Add hidden symbols to fix defaults with CONFIG_DEVEL unset

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/bpf.mk
package/network/config/qosify/Makefile
toolchain/Config.in
tools/Makefile

index 3dc65c76852b80153d3c480dea507b87c45082bc..5211ec44349519db6591ef1d566769f4ad32f83c 100644 (file)
@@ -1,3 +1,5 @@
+BPF_DEPENDS := @HAS_BPF_TOOLCHAIN
+
 ifneq ($(CONFIG_BPF_TOOLCHAIN_HOST),)
   BPF_TOOLCHAIN_HOST_PATH:=$(call qstrip,$(CONFIG_BPF_TOOLCHAIN_HOST_PATH))
   ifneq ($(BPF_TOOLCHAIN_HOST_PATH),)
 ifneq ($(CONFIG_BPF_TOOLCHAIN_HOST),)
   BPF_TOOLCHAIN_HOST_PATH:=$(call qstrip,$(CONFIG_BPF_TOOLCHAIN_HOST_PATH))
   ifneq ($(BPF_TOOLCHAIN_HOST_PATH),)
index 28dedf874dbd5f819ef8c95b6fc5a5890bc895bf..a7532d290672e39566ab46f937cd17f7bf3ebffd 100644 (file)
@@ -29,7 +29,7 @@ define Package/qosify
   CATEGORY:=Kernel modules
   SUBMENU:=Network Support
   TITLE:=A simple QoS solution based eBPF + CAKE
   CATEGORY:=Kernel modules
   SUBMENU:=Network Support
   TITLE:=A simple QoS solution based eBPF + CAKE
-  DEPENDS:=+libbpf +libubox +libubus +kmod-sched-cake +tc-full @!BPF_TOOLCHAIN_NONE
+  DEPENDS:=+libbpf +libubox +libubus +kmod-sched-cake +tc-full $(BPF_DEPENDS)
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
index 15151358065844a6f077977a9ae1134b92fe1d6d..b8b4cfeb885f7fc3051ae9fe3a888148c4b73d3b 100644 (file)
@@ -46,9 +46,11 @@ menuconfig TARGET_OPTIONS
                        bool "None"
 
                config BPF_TOOLCHAIN_HOST
                        bool "None"
 
                config BPF_TOOLCHAIN_HOST
+                       select USE_LLVM_HOST
                        bool "Use host LLVM toolchain"
 
                config BPF_TOOLCHAIN_BUILD_LLVM
                        bool "Use host LLVM toolchain"
 
                config BPF_TOOLCHAIN_BUILD_LLVM
+                       select USE_LLVM_BUILD
                        bool "Build LLVM toolchain for eBPF"
                        help
                          If enabled, a LLVM toolchain for building eBPF binaries will be built.
                        bool "Build LLVM toolchain for eBPF"
                        help
                          If enabled, a LLVM toolchain for building eBPF binaries will be built.
@@ -292,6 +294,17 @@ config GDB_PYTHON
        help
          Enable the python bindings for GDB to allow using python in the gdb shell.
 
        help
          Enable the python bindings for GDB to allow using python in the gdb shell.
 
+config HAS_BPF_TOOLCHAIN
+       bool
+
+config USE_LLVM_HOST
+       select HAS_BPF_TOOLCHAIN
+       bool
+
+config USE_LLVM_BUILD
+       select HAS_BPF_TOOLCHAIN
+       bool
+
 config USE_GLIBC
        default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && (arc)
        bool
 config USE_GLIBC
        default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && (arc)
        bool
index f070692942102fc62effb5fed668e009816a222b..ad8eeb31a4f5d77c63e703b3d65100585855c2a5 100644 (file)
@@ -35,7 +35,7 @@ tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
 tools-$(CONFIG_TARGET_tegra) += cbootimage cbootimage-configs
 tools-$(CONFIG_USES_MINOR) += kernel2minor
 tools-$(CONFIG_USE_SPARSE) += sparse
 tools-$(CONFIG_TARGET_tegra) += cbootimage cbootimage-configs
 tools-$(CONFIG_USES_MINOR) += kernel2minor
 tools-$(CONFIG_USE_SPARSE) += sparse
-tools-$(CONFIG_BPF_TOOLCHAIN_BUILD_LLVM) += llvm-bpf
+tools-$(CONFIG_USE_LLVM_BUILD) += llvm-bpf
 
 # builddir dependencies
 $(curdir)/autoconf/compile := $(curdir)/m4/compile
 
 # builddir dependencies
 $(curdir)/autoconf/compile := $(curdir)/m4/compile