add depends to the default package template
authorFelix Fietkau <nbd@openwrt.org>
Mon, 27 Jun 2005 10:02:35 +0000 (10:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 27 Jun 2005 10:02:35 +0000 (10:02 +0000)
SVN-Revision: 1291

openwrt/package/rules.mk

index 6f2573e9c771faa9d46f1741f4162c930449a515..a95c4e421b025983941696728cfef93e71bd2698 100644 (file)
@@ -13,8 +13,11 @@ ifeq ($(BR2_PACKAGE_$(1)),y)
 install: $$(INFO_$(1))
 endif
 
+IDEPEND_$(1):=$$(strip $(5))
+
 $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
+       if [ "$$(IDEPEND_$(1))" != "" ]; then echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control; fi
        for file in conffiles preinst postinst prerm postrm; do \
                [ -f ./ipkg/$(2).$$$$file ] && cp ./ipkg/$(2).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done