only use the .dev-installed target if Build/InstallDev is defined - avoids unnecessar...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 31 May 2006 16:20:27 +0000 (16:20 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 31 May 2006 16:20:27 +0000 (16:20 +0000)
SVN-Revision: 3866

openwrt/package/rules.mk

index e2e0777da4d4df530cd8f36c63d4f2ad47bb80a1..5d604c50451079232e4e637d65077b09f4bdae6e 100644 (file)
@@ -28,11 +28,11 @@ define Build/DefaultTargets
   $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
        touch $$@
-    
+
   $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
        $(call Build/InstallDev)
        touch $$@
-    
+
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
@@ -263,7 +263,11 @@ else
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured
 
+ifdef Build/InstallDev
   compile-targets: $(PKG_BUILD_DIR)/.dev-installed
+else
+  compile-targets:
+endif
   compile: compile-targets
 
   install-targets: