ramips: enable flashing WizFi630S via OEM firmware
authorTobias Welz <tw@wiznet.eu>
Mon, 3 Aug 2020 19:28:31 +0000 (21:28 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 5 Aug 2020 21:08:03 +0000 (23:08 +0200)
WIZnet WizFi630s board name is written slightly different it its OEM
OpenWrt firmware. This causes an incompatibility warning during flashing
with sysupgrade. This patch is adding the vendor board name to the
supported devices list to avoid this warning. For initial flashing you
can use sysupgrade via command line or luci beside of TFTP.
Do not keep the OEM configuration during sysupgrade.

Signed-off-by: Tobias Welz <tw@wiznet.eu>
target/linux/ramips/image/mt76x8.mk

index d170eaa065a03169d60a9326caab77a3a6f80189..669077c1d350e036f0d1d3f82e8c2a1ffec27f28 100644 (file)
@@ -658,6 +658,7 @@ define Device/wiznet_wizfi630s
   IMAGE_SIZE := 32448k
   DEVICE_VENDOR := WIZnet
   DEVICE_MODEL := WizFi630S
+  SUPPORTED_DEVICES += wizfi630s
 endef
 TARGET_DEVICES += wiznet_wizfi630s