store stamp file for 'development headers installed' in the staging dir instead of...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 2 Jun 2006 16:12:05 +0000 (16:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 2 Jun 2006 16:12:05 +0000 (16:12 +0000)
SVN-Revision: 3895

openwrt/package/rules.mk

index 79c2b3460d8223ae32c1059a103345e8f9954f02..1fd6f2a8ab7abcfa5012d538249bbac88daf37cf 100644 (file)
@@ -29,17 +29,18 @@ define Build/DefaultTargets
        $(call Build/Compile)
        touch $$@
 
-  $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
+  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
        $(call Build/InstallDev)
        touch $$@
        
   ifdef Build/InstallDev
-    compile-targets: $(PKG_BUILD_DIR)/.dev-installed
+    compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
   endif
 
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
+       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
        @-rm $(PKG_BUILD_DIR)/.built