remove some debugging code, include package/rules.mk in package dependency check
authorFelix Fietkau <nbd@openwrt.org>
Thu, 1 Jun 2006 00:31:20 +0000 (00:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 1 Jun 2006 00:31:20 +0000 (00:31 +0000)
SVN-Revision: 3884

openwrt/package/rules.mk

index 61c2ae3eb0876b40b79d79fe8b9698bbd5a9963e..4a8d947161ccf5ac3db667f05849800857ff165b 100644 (file)
@@ -6,11 +6,11 @@ endif
 
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . | tee /tmp/xy1),.)
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
       $(PKG_BUILD_DIR)/.prepared: package-clean
     endif
 
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/xy2),$(IPKG_$(1)))
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
       $(PKG_BUILD_DIR)/.built: package-rebuild
     endif
   endif