ath79: add support for TP-Link Archer C2 V3 (AC900)
authorSkirmantas Lauzikas <skirmantas.lauzikas@blackraven.lt>
Sun, 28 Oct 2018 04:30:52 +0000 (06:30 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sun, 27 Jan 2019 15:41:10 +0000 (16:41 +0100)
This commit adds support for the TP-link Archer C2 V3 (AC900).

Specifications:

 - CPU: QCA9563 750Mhz
 - Ram: 64MB (DDR2)
 - Flash: 8MB (SPI NOR)
 - Ethernet: 5x 10/100/1000
 - Wifi: QCA9563 bgn + QCA9887 an+ac
 - 9x Leds, 2x buttons

Flash instructions:

Upload openwrt-ath79-generic-tplink_archer-c2-v3-squashfs-factory.bin
via the router Web interface and flash as normal firmware update.

Signed-off-by: Skirmantas Lauzikas <skirmantas.lauzikas@blackraven.lt>
[reorder entries, fix trailing whitespace in dts, add firmware partition
 compatible string, remove led default off states, use default on state
 for system led, reuse tplink-safeloader-uimage image build recipe, squash
 with dynamic partitioning commit, reword commit message, add
 installation instructions]
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9563_tplink_archer-c2-v3.dts [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index c5ea726ce497bc0fa89559eba778640f48610e6b..1c9d43edbabc0195024cbe7da498f58e25317ba9 100755 (executable)
@@ -81,6 +81,14 @@ tplink,archer-c7-v5)
        ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x10"
        ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x20"
        ;;
+tplink,archer-c2-v3|\
+tplink,tl-wr1043nd-v4)
+       ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x20"
+       ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
+       ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
+       ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x04"
+       ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
+       ;;
 tplink,archer-c58-v1|\
 tplink,archer-c59-v1)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
@@ -98,13 +106,6 @@ tplink,tl-mr3020-v1|\
 tplink,tl-mr3040-v2)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
        ;;
-tplink,tl-wr1043nd-v4)
-       ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x20"
-       ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
-       ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
-       ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x04"
-       ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
-       ;;
 tplink,tl-wr740n-v1|\
 tplink,tl-wr740n-v3|\
 tplink,tl-wr741-v1|\
index 4197f331b7598798bbbf99c82dd5d58f018ccb0c..6f3ef614db5983ca89205f30cec3b2be1f328315 100755 (executable)
@@ -74,6 +74,7 @@ ath79_setup_interfaces()
        dlink,dir-825-c1|\
        dlink,dir-835-a1|\
        dlink,dir-859-a1|\
+       tplink,archer-c2-v3|\
        tplink,tl-wr1043nd-v4)
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan"
index 84e43ceee5187b3c1b982878d38112cda402d267..da6c14af1774948cc4243032336fc0bdb3ab15e0 100644 (file)
@@ -126,6 +126,10 @@ case "$FIRMWARE" in
                ath10kcal_extract "ART" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
                ;;
+       tplink,archer-c2-v3)
+               ath10kcal_extract "ART" 20480 2116
+               ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) -1)
+               ;;
        tplink,archer-c7-v2)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -1)
diff --git a/target/linux/ath79/dts/qca9563_tplink_archer-c2-v3.dts b/target/linux/ath79/dts/qca9563_tplink_archer-c2-v3.dts
new file mode 100644 (file)
index 0000000..9686290
--- /dev/null
@@ -0,0 +1,185 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       compatible = "tplink,archer-c2-v3", "qca,qca9563";
+       model = "TP-Link Archer C2 Version 3";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &system;
+               led-failsafe = &system;
+               led-running = &system;
+               led-upgrade = &system;
+       };
+
+       gpio_leds: leds {
+               compatible = "gpio-leds";
+
+               system: system {
+                       label = "tp-link:green:system";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wifi2g {
+                       label = "tp-link:green:wifi2g";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wifi5g {
+                       label = "tp-link:green:wifi5g";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wifi_wps {
+                       label = "tp-link:green:wps";
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               };
+
+               wan {
+                       label = "tp-link:green:wan";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_fail {
+                       label = "tp-link:orange:wan";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               lan1 {
+                       label = "tp-link:green:lan1";
+                       gpios = <&gpio 9 GPIO_ACTIVE_LOW>;
+               };
+
+               lan2 {
+                       label = "tp-link:green:lan2";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               lan3 {
+                       label = "tp-link:green:lan3";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               lan4 {
+                       label = "tp-link:green:lan4";
+                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "WPS button";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "factory-uboot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "uboot";
+                               reg = <0x020000 0x10000>;
+                       };
+
+                       partition@30000 {
+                               label = "firmware";
+                               reg = <0x030000 0x7A0000>;
+                               compatible = "denx,uimage";
+                       };
+
+                       info: partition@7e0000 {
+                               label = "product-info";
+                               reg = <0x7e0000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "ART";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&gpio {
+       status = "okay";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0>;
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+               >;
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&info 0x8>;
+       phy-mode = "sgmii";
+       phy-handle = <&phy0>;
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&info 0x8>;
+};
index be755c7ec08b71a1463c40d2a8aeceb8e206e67a..52a181c353ca63b2f003f4454c7a16c962300c0e 100644 (file)
@@ -12,6 +12,16 @@ define Device/tplink_archer-a7-v5
 endef
 TARGET_DEVICES += tplink_archer-a7-v5
 
+define Device/tplink_archer-c2-v3
+  $(Device/tplink-safeloader-uimage)
+  ATH_SOC := qca9563
+  IMAGE_SIZE := 7808k
+  DEVICE_TITLE := TP-LINK Archer C2 v3
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
+  TPLINK_BOARD_ID := ARCHER-C2-V3
+endef
+TARGET_DEVICES += tplink_archer-c2-v3
+
 define Device/tplink_archer-c58-v1
   $(Device/tplink-safeloader-uimage)
   ATH_SOC := qca9561
index 65034e3804067d11bbcd065f517729eccf5111a4..075cd8a7edd1e842622a4843dea5c6e658a12d00 100644 (file)
@@ -397,6 +397,44 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "file-system",
        },
 
+       /** Firmware layout for the C2v3 */
+       {
+               .id = "ARCHER-C2-V3",
+               .support_list =
+                       "SupportList:\n"
+                       "{product_name:ArcherC2,product_ver:3.0.0,special_id:00000000}\n"
+                       "{product_name:ArcherC2,product_ver:3.0.0,special_id:55530000}\n"
+                       "{product_name:ArcherC2,product_ver:3.0.0,special_id:45550000}\n",
+               .support_trail = '\x00',
+               .soft_ver = "soft_ver:3.0.1\n",
+
+               /** We're using a dynamic kernel/rootfs split here */
+
+               .partitions = {
+                       {"factory-boot", 0x00000, 0x20000},
+                       {"fs-uboot", 0x20000, 0x10000},
+                       {"firmware", 0x30000, 0x7a0000},
+                       {"user-config", 0x7d0000, 0x04000},
+                       {"default-mac", 0x7e0000, 0x00100},
+                       {"device-id", 0x7e0100, 0x00100},
+                       {"extra-para", 0x7e0200, 0x00100},
+                       {"pin", 0x7e0300, 0x00100},
+                       {"support-list", 0x7e0400, 0x00400},
+                       {"soft-version", 0x7e0800, 0x00400},
+                       {"product-info", 0x7e0c00, 0x01400},
+                       {"partition-table", 0x7e2000, 0x01000},
+                       {"profile", 0x7e3000, 0x01000},
+                       {"default-config", 0x7e4000, 0x04000},
+                       {"merge-config", 0x7ec000, 0x02000},
+                       {"qos-db", 0x7ee000, 0x02000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "file-system",
+       },
+
        /** Firmware layout for the C25v1 */
        {
                .id = "ARCHER-C25-V1",