Allow downloading of files with undefined mdsum (to ease updating packages)
authorNicolas Thill <nico@openwrt.org>
Sat, 21 May 2005 10:57:17 +0000 (10:57 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 21 May 2005 10:57:17 +0000 (10:57 +0000)
SVN-Revision: 1005

openwrt/package/rules.mk

index 51be45814d09142f54034f3ffbc00d90b5ac4824..03b750f50e8dfca0c960b737460c0cb64db8ccaa 100644 (file)
@@ -29,7 +29,7 @@ endef
 
 ifneq ($(strip $(PKG_SOURCE)),)
 $(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL)
 endif
 
 ifneq ($(strip $(PKG_CAT)),)