Add frickin package
authorNicolas Thill <nico@openwrt.org>
Tue, 24 May 2005 01:55:36 +0000 (01:55 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 24 May 2005 01:55:36 +0000 (01:55 +0000)
SVN-Revision: 1042

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/frickin/Config.in [new file with mode: 0644]
openwrt/package/frickin/Makefile [new file with mode: 0644]
openwrt/package/frickin/files/frickin.default [new file with mode: 0644]
openwrt/package/frickin/files/frickin.init [new file with mode: 0644]
openwrt/package/frickin/ipkg/frickin.conffiles [new file with mode: 0644]
openwrt/package/frickin/ipkg/frickin.control [new file with mode: 0644]

index 5f42885ce8637c89d97e87f6eac3fcac64ea099d..49c540e1a804e70c10c8ec2cf0f07222a404553f 100644 (file)
@@ -33,6 +33,7 @@ source "package/ez-ipupdate/Config.in"
 source "package/fping/Config.in"
 source "package/fprobe/Config.in"
 source "package/freeradius/Config.in"
+source "package/frickin/Config.in"
 source "package/howl/Config.in"
 source "package/htpdate/Config.in"
 source "package/iproute2/Config.in"
index 451fdd078d6d2ccbc9b09d67aefc8cb41395fbee..2a2aca6268c294f7f5d4625e60742f49b575f7ff 100644 (file)
@@ -22,6 +22,7 @@ package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
 package-$(BR2_PACKAGE_FPING) += fping
 package-$(BR2_PACKAGE_FPROBE) += fprobe
 package-$(BR2_PACKAGE_FREERADIUS) += freeradius
+package-$(BR2_PACKAGE_FRICKIN) += frickin
 package-$(BR2_PACKAGE_FUSE) += fuse
 package-$(BR2_PACKAGE_GLIB) += glib
 package-$(BR2_PACKAGE_GMP) += gmp
diff --git a/openwrt/package/frickin/Config.in b/openwrt/package/frickin/Config.in
new file mode 100644 (file)
index 0000000..6747197
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_FRICKIN
+       tristate "frickin - PPTP (Point-to-Point Tunneling Protocol) proxy"
+#      default m if CONFIG_DEVEL
+       default n
+       help
+         Frickin PPTP Proxy allows a Point-to-Point Tunneling Protocol (PPTP) 
+         client to connect to a PPTP server through Network Address 
+         Translation (NAT).
+         
+         http://frickin.sourceforge.net/
+         
+         
diff --git a/openwrt/package/frickin/Makefile b/openwrt/package/frickin/Makefile
new file mode 100644 (file)
index 0000000..15072ac
--- /dev/null
@@ -0,0 +1,39 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=frickin
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
+PKG_MD5SUM:= dd703f9202b3c0e55237d04ea429c684
+
+PKG_SOURCE_URL:=@SF/frickin
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FRICKIN,frickin,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all
+       touch $@
+
+$(IPKG_FRICKIN):
+       install -d -m0755 $(IDIR_FRICKIN)/etc/default
+       install -m0644 ./files/frickin.default $(IDIR_FRICKIN)/etc/default/frickin
+       install -d -m0755 $(IDIR_FRICKIN)/etc/init.d
+       install -m0755 ./files/frickin.init $(IDIR_FRICKIN)/etc/init.d/frickin
+       install -d -m0755 $(IDIR_FRICKIN)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/frickin $(IDIR_FRICKIN)/usr/sbin/
+       $(RSTRIP) $(IDIR_FRICKIN)
+       $(IPKG_BUILD) $(IDIR_FRICKIN) $(PACKAGE_DIR)
diff --git a/openwrt/package/frickin/files/frickin.default b/openwrt/package/frickin/files/frickin.default
new file mode 100644 (file)
index 0000000..9f55d5b
--- /dev/null
@@ -0,0 +1,16 @@
+# ip address of the server the proxy should connect to
+TARGET_IP=192.168.1.2
+
+# ip address the proxy should listen to for incoming connections
+#LISTEN_IP=192.168.1.1
+
+# maximum number of simultaneous connections
+#PROXY_CONN_MAX=20
+
+# user the proxy should run as
+#PROXY_USER=root
+
+[ -n "$TARGET_IP" ] && OPTIONS="$OPTIONS -s $TARGET_IP"
+[ -n "$LISTEN_IP" ] && OPTIONS="$OPTIONS -l $LISTEN_IP"
+[ -n "$PROXY_CONN_MAX" ] && OPTIONS="$OPTIONS -c $PROXY_CONN_MAX"
+[ -n "$PROXY_USER" ] && OPTIONS="$OPTIONS -u $PROXY_USER"
diff --git a/openwrt/package/frickin/files/frickin.init b/openwrt/package/frickin/files/frickin.init
new file mode 100644 (file)
index 0000000..0a80d41
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+BIN=frickin
+DEFAULT=/etc/default/$BIN
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  $BIN $OPTIONS
+  ;;
+ *)
+  echo "usage: $0 (start)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/frickin/ipkg/frickin.conffiles b/openwrt/package/frickin/ipkg/frickin.conffiles
new file mode 100644 (file)
index 0000000..f374430
--- /dev/null
@@ -0,0 +1 @@
+/etc/default/frickin
diff --git a/openwrt/package/frickin/ipkg/frickin.control b/openwrt/package/frickin/ipkg/frickin.control
new file mode 100644 (file)
index 0000000..a5f195d
--- /dev/null
@@ -0,0 +1,8 @@
+Package: frickin
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/frickin/
+Description: PPTP (Point-to-Point Tunneling Protocol) proxy