toolchain/gdb: use STAGING_DIR_HOST instead of hardcoding default
authorChristian Marangi <ansuelsmth@gmail.com>
Fri, 2 Dec 2022 19:33:14 +0000 (20:33 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 9 Jan 2023 20:33:19 +0000 (21:33 +0100)
Use STAGING_DIR_HOST to reference staging host directory instead of
hardcoding it to default path.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
toolchain/gdb/Makefile

index 4587c591f4ea721f98563d255252c961bd80d004..70a4fa59026fc67ae9e340c0bd46cf91ad1f249d 100644 (file)
@@ -30,10 +30,10 @@ HOST_CONFIGURE_ARGS = \
        --build=$(GNU_HOST_NAME) \
        --host=$(GNU_HOST_NAME) \
        --target=$(REAL_GNU_TARGET_NAME) \
-       --with-gmp=$(TOPDIR)/staging_dir/host \
-       --with-mpfr=$(TOPDIR)/staging_dir/host \
-       --with-mpc=$(TOPDIR)/staging_dir/host \
-       --with-expat=$(TOPDIR)/staging_dir/host \
+       --with-gmp=$(STAGING_DIR_HOST) \
+       --with-mpfr=$(STAGING_DIR_HOST) \
+       --with-mpc=$(STAGING_DIR_HOST) \
+       --with-expat=$(STAGING_DIR_HOST) \
        --disable-werror \
        --without-uiout \
        --enable-tui --disable-gdbtk --without-x \