add initial video4linux support (for usb webcams) to head
authorNicolas Thill <nico@openwrt.org>
Sun, 14 Aug 2005 03:01:53 +0000 (03:01 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 14 Aug 2005 03:01:53 +0000 (03:01 +0000)
SVN-Revision: 1654

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-pwc.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-videodev.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm
openwrt/target/linux/linux-2.4/config/soekris

index 1fa905042060e618bbbdfc2f247c8b204d2cfe73..891f8f0faa53fdcdd4a41f092227b08bebe8b148 100644 (file)
@@ -324,6 +324,13 @@ config BR2_PACKAGE_KMOD_SCHED
        help
          Kernel schedulers for IP traffic
 
+config BR2_PACKAGE_KMOD_VIDEODEV
+       tristate "Video (For Linux) kernel support"
+       default m
+
+config BR2_PACKAGE_KMOD_PWC
+       tristate "Kernel driver for USB Philips Cameras"
+       default m
 
 config BR2_PACKAGE_KMOD_NATSEMI
        tristate "Soekris net4801 ethernet driver"
diff --git a/openwrt/target/linux/control/kmod-pwc.control b/openwrt/target/linux/control/kmod-pwc.control
new file mode 100644 (file)
index 0000000..ecd5485
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-pwc
+Priority: optional
+Section: sys
+Maintainer: Nicolas Thill <nico@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/target/linux/linux-2.4/
+Description: Kernel driver for USB Philips Cameras
diff --git a/openwrt/target/linux/control/kmod-videodev.control b/openwrt/target/linux/control/kmod-videodev.control
new file mode 100644 (file)
index 0000000..c852683
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-videodev
+Priority: optional
+Section: sys
+Maintainer: Nicolas Thill <nico@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/target/linux/linux-2.4/
+Description: Video For Linux kernel support
index ff3cbb6e13929d3533ccee990073ae9a3c5cd68b..0fcf441a88de044f6403f34e3a27c144fa40eb9d 100644 (file)
@@ -171,6 +171,12 @@ $(eval $(call KMOD_template,GRE,gre,\
 $(eval $(call KMOD_template,SCHED,sched,\
        $(MODULES_DIR)/kernel/net/sched/*.o \
 ))
+$(eval $(call KMOD_template,VIDEODEV,videodev,\
+       $(MODULES_DIR)/kernel/drivers/media/video/videodev.o \
+))
+$(eval $(call KMOD_template,PWC,pwc,\
+       $(MODULES_DIR)/kernel/drivers/usb/pwc.o \
+))
 
 $(TARGETS): $(PACKAGE_DIR)
 
index 6ed41112e5f76c27e62ab6b5616b8d9d522abd1a..f8e50d76fcc55890e9b08e0b885c89d31386a644 100644 (file)
@@ -1072,7 +1072,35 @@ CONFIG_NLS_DEFAULT="iso8859-1"
 #
 # Multimedia devices
 #
-# CONFIG_VIDEO_DEV is not set
+CONFIG_VIDEO_DEV=m
+
+#
+# Video For Linux
+#
+CONFIG_VIDEO_PROC_FS=y
+# CONFIG_I2C_PARPORT is not set
+# CONFIG_VIDEO_BT848 is not set
+# CONFIG_VIDEO_PMS is not set
+# CONFIG_VIDEO_BWQCAM is not set
+# CONFIG_VIDEO_CQCAM is not set
+# CONFIG_VIDEO_CPIA is not set
+# CONFIG_VIDEO_SAA5249 is not set
+# CONFIG_TUNER_3036 is not set
+# CONFIG_VIDEO_STRADIS is not set
+# CONFIG_VIDEO_ZORAN is not set
+# CONFIG_VIDEO_ZORAN_BUZ is not set
+# CONFIG_VIDEO_ZORAN_DC10 is not set
+# CONFIG_VIDEO_ZORAN_LML33 is not set
+# CONFIG_VIDEO_ZR36120 is not set
+# CONFIG_VIDEO_MEYE is not set
+
+#
+# Radio Adapters
+#
+# CONFIG_RADIO_GEMTEK_PCI is not set
+# CONFIG_RADIO_MAXIRADIO is not set
+# CONFIG_RADIO_MAESTRO is not set
+# CONFIG_RADIO_MIROPCM20 is not set
 
 #
 # Sound
@@ -1119,6 +1147,16 @@ CONFIG_USB_PRINTER=m
 # CONFIG_USB_SCANNER is not set
 # CONFIG_USB_MICROTEK is not set
 # CONFIG_USB_HPUSBSCSI is not set
+# CONFIG_USB_IBMCAM is not set
+# CONFIG_USB_KONICAWC is not set
+# CONFIG_USB_OV511 is not set
+CONFIG_USB_PWC=m
+# CONFIG_USB_SE401 is not set
+# CONFIG_USB_STV680 is not set
+# CONFIG_USB_W9968CF is not set
+# CONFIG_USB_VICAM is not set
+# CONFIG_USB_DSBR is not set
+# CONFIG_USB_DABUSB is not set
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
 # CONFIG_USB_KAWETH is not set
index aa987110b2c52fca3494e2dbd56ffcf4a09b57de..4fdb6a2be0505dbd1db75e68c94daabe2964c5cf 100644 (file)
@@ -1044,6 +1044,50 @@ CONFIG_NLS_DEFAULT="iso8859-1"
 # CONFIG_NLS_KOI8_U is not set
 # CONFIG_NLS_UTF8 is not set
 
+#
+# Multimedia devices
+#
+CONFIG_VIDEO_DEV=m
+
+#
+# Video For Linux
+#
+CONFIG_VIDEO_PROC_FS=y
+# CONFIG_I2C_PARPORT is not set
+# CONFIG_VIDEO_BT848 is not set
+# CONFIG_VIDEO_PMS is not set
+# CONFIG_VIDEO_BWQCAM is not set
+# CONFIG_VIDEO_CQCAM is not set
+# CONFIG_VIDEO_CPIA is not set
+# CONFIG_VIDEO_SAA5249 is not set
+# CONFIG_TUNER_3036 is not set
+# CONFIG_VIDEO_STRADIS is not set
+# CONFIG_VIDEO_ZORAN is not set
+# CONFIG_VIDEO_ZORAN_BUZ is not set
+# CONFIG_VIDEO_ZORAN_DC10 is not set
+# CONFIG_VIDEO_ZORAN_LML33 is not set
+# CONFIG_VIDEO_ZR36120 is not set
+# CONFIG_VIDEO_MEYE is not set
+
+#
+# Radio Adapters
+#
+# CONFIG_RADIO_CADET is not set
+# CONFIG_RADIO_RTRACK is not set
+# CONFIG_RADIO_RTRACK2 is not set
+# CONFIG_RADIO_AZTECH is not set
+# CONFIG_RADIO_GEMTEK is not set
+# CONFIG_RADIO_GEMTEK_PCI is not set
+# CONFIG_RADIO_MAXIRADIO is not set
+# CONFIG_RADIO_MAESTRO is not set
+# CONFIG_RADIO_MIROPCM20 is not set
+# CONFIG_RADIO_SF16FMI is not set
+# CONFIG_RADIO_SF16FMR2 is not set
+# CONFIG_RADIO_TERRATEC is not set
+# CONFIG_RADIO_TRUST is not set
+# CONFIG_RADIO_TYPHOON is not set
+# CONFIG_RADIO_ZOLTRIX is not set
+
 #
 # Sound
 #
@@ -1091,6 +1135,16 @@ CONFIG_USB_PRINTER=m
 # CONFIG_USB_SCANNER is not set
 # CONFIG_USB_MICROTEK is not set
 # CONFIG_USB_HPUSBSCSI is not set
+# CONFIG_USB_IBMCAM is not set
+# CONFIG_USB_KONICAWC is not set
+# CONFIG_USB_OV511 is not set
+CONFIG_USB_PWC=m
+# CONFIG_USB_SE401 is not set
+# CONFIG_USB_STV680 is not set
+# CONFIG_USB_W9968CF is not set
+# CONFIG_USB_VICAM is not set
+# CONFIG_USB_DSBR is not set
+# CONFIG_USB_DABUSB is not set
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
 # CONFIG_USB_KAWETH is not set