ath79: increase kernel partition size for CPE610v1
authorAndrew Cameron <apcameron@softhome.net>
Sun, 30 Jun 2019 02:45:09 +0000 (21:45 -0500)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 7 Jul 2019 11:02:06 +0000 (13:02 +0200)
Increase the Kernel partition to address the issue discussed here
https://forum.openwrt.org/t/cpe610-v1-sysupgrade-bin-missing-too-big/39637/5
Switch Back to the okli Loader to support increased partition size

Signed-off-by: Andrew Cameron <apcameron@softhome.net>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [add <> for e-mail]
target/linux/ath79/dts/ar9344_tplink_cpe610-v1.dts
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 5b7c32c6b709e5507fa384ef7476a45359b10665..8a78dc4fa4548b8da7858d1a8355a58c370b454e 100644 (file)
 
                                partition@0 {
                                        label = "kernel";
-                                       reg = <0x000000 0x1c0000>;
+                                       reg = <0x000000 0x200000>;
                                };
 
-                               partition@1c0000 {
+                               partition@200000 {
                                        label = "rootfs";
-                                       reg = <0x1c0000 0x5c0000>;
+                                       reg = <0x200000 0x580000>;
                                };
                        };
 
index ec250a540426ccdf4032577b5b3618dbb94e4f16..f0d0a5cd07c1506c56b8ea5025eecf0410d308ae 100644 (file)
@@ -167,7 +167,10 @@ define Device/tplink_cpe610-v1
   DEVICE_VARIANT := v1
   TPLINK_BOARD_ID := CPE610V1
   LOADER_TYPE := elf
-  KERNEL := kernel-bin | append-dtb | lzma | loader-kernel
+  LOADER_FLASH_OFFS := 0x43000
+  COMPILE := loader-$(1).elf
+  COMPILE/loader-$(1).elf := loader-okli-compile
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 12288
 endef
 TARGET_DEVICES += tplink_cpe610-v1
 
index 1a54e92b07cd398d3c1b4e165baf5f129369a3d5..78d80ac89ece4e81538807b2132c04981b518272 100644 (file)
@@ -303,8 +303,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x1c0000},
-                       {"file-system", 0x200000, 0x5b0000},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},