update iproute2 to new packaging style
authorFelix Fietkau <nbd@openwrt.org>
Thu, 12 May 2005 20:45:01 +0000 (20:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 12 May 2005 20:45:01 +0000 (20:45 +0000)
SVN-Revision: 859

openwrt/package/iproute2/Makefile
openwrt/package/iproute2/ip.control [deleted file]
openwrt/package/iproute2/ipkg/ip.control [new file with mode: 0644]
openwrt/package/iproute2/ipkg/tc.control [new file with mode: 0644]
openwrt/package/iproute2/tc.control [deleted file]

index 5c6b96eb0fd61c0052089165a94729d886d0356a..d832b755366ec022baea9e18ad373dd666061d66 100644 (file)
@@ -12,24 +12,13 @@ PKG_SOURCE:=$(PKG_NAME)-2.6.9-041019.tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-2.6.9
 PKG_CAT:=zcat
 
-PKG_IP:=$(PACKAGE_DIR)/ip_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IP_DIR:=$(PKG_BUILD_DIR)/ipkg/ip
+include $(TOPDIR)/package/rules.mk
 
-PKG_TC:=$(PACKAGE_DIR)/tc_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_TC_DIR:=$(PKG_BUILD_DIR)/ipkg/tc
+$(eval $(call PKG_template,IPROUTE2_IP,ip,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,IPROUTE2_TC,tc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-.NOTPARALLEL:
-
-$(DL_DIR)/$(PKG_SOURCE):
-        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
-
-$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
+$(PKG_BUILD_DIR)/.configured:
        $(SED) "s:-O2:${TARGET_CFLAGS}:g" $(PKG_BUILD_DIR)/Makefile
-       touch $(PKG_BUILD_DIR)/.patched
-
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
        $(SED) "s,-I/usr/include/db3,," $(PKG_BUILD_DIR)/Makefile
        $(SED) "s,^KERNEL_INCLUDE.*,KERNEL_INCLUDE=$(LINUX_DIR)/include," \
                $(PKG_BUILD_DIR)/Makefile
@@ -38,58 +27,21 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
        # For now disable compiling of the misc directory because it seems to fail
        rm -rf $(PKG_BUILD_DIR)/misc 
        $(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
-       touch $(PKG_BUILD_DIR)/.configured
-
-$(PKG_BUILD_DIR)/tc/tc: $(PKG_BUILD_DIR)/.configured
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc
-
-$(PKG_BUILD_DIR)/ip/ip: $(PKG_BUILD_DIR)/.configured
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all ip/ip
-
-
-$(PKG_IP): $(PKG_BUILD_DIR)/ip/ip $(PACKAGE_DIR)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IP_DIR) ip.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_IP_DIR)/usr/sbin
-       cp $< $(PKG_IP_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IP_DIR)/usr/sbin/*
-       $(IPKG_BUILD) $(PKG_IP_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/ip.list: $(PKG_IP)
-       $(IPKG) install $(PKG_IP)
-
-$(PKG_TC): $(PKG_BUILD_DIR)/tc/tc $(PACKAGE_DIR)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_TC_DIR) tc.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_TC_DIR)/usr/sbin
-       cp $< $(PKG_TC_DIR)/usr/sbin/
-       $(STRIP) $(PKG_TC_DIR)/usr/sbin/*
-       $(IPKG_BUILD) $(PKG_TC_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/tc.list: $(PKG_TC)
-       $(IPKG) install $(PKG_TC)
-
-$(PACKAGE_DIR):
-       mkdir -p $(PACKAGE_DIR)
+       touch $@
 
-TARGETS:=
-ifneq ($(BR2_PACKAGE_IPROUTE2_IP),)
-TARGETS += $(PKG_IP)
-endif
-ifneq ($(BR2_PACKAGE_IPROUTE2_TC),)
-TARGETS += $(PKG_TC)
-endif
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
+       touch $@
 
-ifeq ($(BR2_PACKAGE_IPROUTE2_IP),y)
-INSTALL_TARGETS += $(IPKG_STATE_DIR)/info/ip.list
-endif
-ifeq ($(BR2_PACKAGE_IPROUTE2_TC),y)
-INSTALL_TARGETS += $(IPKG_STATE_DIR)/info/tc.list
-endif
+$(IPKG_IPROUTE2_IP):
+       mkdir -p $(IDIR_IPROUTE2_IP)/usr/sbin
+       cp $(PKG_BUILD_DIR)/ip/ip $(IDIR_IPROUTE2_IP)/usr/sbin/
+       $(STRIP) $(IDIR_IPROUTE2_IP)/usr/sbin/*
+       $(IPKG_BUILD) $(IDIR_IPROUTE2_IP) $(PACKAGE_DIR)
 
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.patched
-compile: $(TARGETS)
-install: $(INSTALL_TARGETS)
+$(IPKG_IPROUTE2_TC):
+       mkdir -p $(IDIR_IPROUTE2_TC)/usr/sbin
+       cp $(PKG_BUILD_DIR)/ip/ip $(IDIR_IPROUTE2_TC)/usr/sbin/
+       $(STRIP) $(IDIR_IPROUTE2_TC)/usr/sbin/*
+       $(IPKG_BUILD) $(IDIR_IPROUTE2_TC) $(PACKAGE_DIR)
 
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IP) $(PKG_TC)
diff --git a/openwrt/package/iproute2/ip.control b/openwrt/package/iproute2/ip.control
deleted file mode 100644 (file)
index c585077..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: ip
-Section: net
-Priority: optional
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: iproute2 routing control utility
diff --git a/openwrt/package/iproute2/ipkg/ip.control b/openwrt/package/iproute2/ipkg/ip.control
new file mode 100644 (file)
index 0000000..c585077
--- /dev/null
@@ -0,0 +1,6 @@
+Package: ip
+Section: net
+Priority: optional
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: iproute2 routing control utility
diff --git a/openwrt/package/iproute2/ipkg/tc.control b/openwrt/package/iproute2/ipkg/tc.control
new file mode 100644 (file)
index 0000000..a63fd65
--- /dev/null
@@ -0,0 +1,7 @@
+Package: tc
+Section: net
+Priority: optional
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: iproute2 traffic control utility
+Depends: kmod-sched
diff --git a/openwrt/package/iproute2/tc.control b/openwrt/package/iproute2/tc.control
deleted file mode 100644 (file)
index a63fd65..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: tc
-Section: net
-Priority: optional
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: iproute2 traffic control utility
-Depends: kmod-sched