add target package/target_name to the master makefile, which will run $(MAKE) -C...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Jun 2005 14:05:22 +0000 (14:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Jun 2005 14:05:22 +0000 (14:05 +0000)
SVN-Revision: 1147

openwrt/Makefile

index e935295e6c41e331278d9ba62dbea71b44e32e57..1b8d968a0995a291cdb0fd549542daf81c5c5ff7 100644 (file)
@@ -74,7 +74,6 @@ package_install: package_compile toolchain
 #
 #############################################################
 
-
 # In this section, we need .config
 include .config.cmd
 
@@ -108,6 +107,16 @@ $(BUILD_DIR):
 
 source: $(TARGETS_SOURCE)
 
+
+package/%:
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+       $(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
 #############################################################
 #
 # Cleanup and misc junk