add wknock package (thanks to Florian Fainelli)
authorNicolas Thill <nico@openwrt.org>
Mon, 7 Nov 2005 00:46:37 +0000 (00:46 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 7 Nov 2005 00:46:37 +0000 (00:46 +0000)
SVN-Revision: 2362

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/wknock/Config.in [new file with mode: 0644]
openwrt/package/wknock/Makefile [new file with mode: 0644]
openwrt/package/wknock/ipkg/wknock.control [new file with mode: 0644]

index 2b59f05693768eb9e9efd145c39e5d039e37a88a..8cf05585ad6dd45cef1535cdeb90b4fac655ab07 100644 (file)
@@ -130,6 +130,7 @@ source "package/wificonf/Config.in"
 source "package/wifidog/Config.in"
 source "package/wireless-tools/Config.in"
 source "package/wiviz/Config.in"
+source "package/wknock/Config.in"
 source "package/wol/Config.in"
 source "package/wondershaper/Config.in"
 source "package/wpa_supplicant/Config.in"
index e628961e5ba06a4f0678d97a9454f7dc914d6899..ff6bc640fa16d246ce64c2842e6bba26e2911f26 100644 (file)
@@ -202,6 +202,7 @@ package-$(BR2_PACKAGE_WIFICONF) += wificonf
 package-$(BR2_PACKAGE_WIFIDOG) += wifidog
 package-$(BR2_PACKAGE_WIVIZ) += wiviz
 package-$(BR2_PACKAGE_WIRELESS_TOOLS) += wireless-tools
+package-$(BR2_PACKAGE_WKNOCK) += wknock
 package-$(BR2_PACKAGE_WOL) += wol
 package-$(BR2_PACKAGE_WONDERSHAPER) += wondershaper
 package-$(BR2_PACKAGE_WPA_SUPPLICANT) += wpa_supplicant
@@ -301,6 +302,7 @@ tor-compile: libevent-compile openssl-compile zlib-compile
 usbutils-compile: libusb-compile
 vtun-compile: zlib-compile openssl-compile lzo-compile
 wificonf-compile: wireless-tools-compile nvram-compile
+wknock-compile: libpcap-compile
 wpa_supplicant-compile: openssl-compile
 xsupplicant-compile: openssl-compile
 
diff --git a/openwrt/package/wknock/Config.in b/openwrt/package/wknock/Config.in
new file mode 100644 (file)
index 0000000..106068d
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_WKNOCK
+       prompt "wknock............................ A tool to hide your Access Point against opportunistic attackers."
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBPCAP
+       help
+         A tool to hide your Access Point against opportunistic attackers.
+         
+         http://www.rstack.org/oudot/wknock/
+
diff --git a/openwrt/package/wknock/Makefile b/openwrt/package/wknock/Makefile
new file mode 100644 (file)
index 0000000..de5d0ea
--- /dev/null
@@ -0,0 +1,36 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wknock
+PKG_VERSION:=1
+PKG_RELEASE:=1
+PKG_MD5SUM:=6b7a1f3cbb0af88da02e5d30cefd8e7f
+
+PKG_SOURCE_URL:=http://blackhat.com/presentations/bh-europe-05/BH_EU_05-Oudot/
+PKG_SOURCE:=$(PKG_NAME).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WKNOCK,wknock,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpcap" \
+               all
+       touch $@
+
+$(IPKG_WKNOCK):
+       install -d -m0755 $(IDIR_WKNOCK)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/wknock $(IDIR_WKNOCK)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/wknock-ng $(IDIR_WKNOCK)/usr/sbin/
+       $(RSTRIP) $(IDIR_WKNOCK)/
+       $(IPKG_BUILD) $(IDIR_WKNOCK) $(PACKAGE_DIR)
diff --git a/openwrt/package/wknock/ipkg/wknock.control b/openwrt/package/wknock/ipkg/wknock.control
new file mode 100644 (file)
index 0000000..e781dae
--- /dev/null
@@ -0,0 +1,5 @@
+Package: wknock
+Section: net
+Priority: optional
+Depends: libpcap, wl
+Description: A tool to hide your Access Point against opportunistic attackers.