ath79: rename TP-Link TL-WPA8630P v2 (EU) to v2.0 (EU)
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 28 Sep 2020 12:31:02 +0000 (14:31 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 4 Oct 2020 13:44:05 +0000 (15:44 +0200)
Since we have a v2.1 (EU) with different partitioning now, rename
the v2.0 to make the difference visible to the user more directly.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/qca9563_tplink_tl-wpa8630p-v2-eu.dts [deleted file]
target/linux/ath79/dts/qca9563_tplink_tl-wpa8630p-v2.0-eu.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

diff --git a/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630p-v2-eu.dts b/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630p-v2-eu.dts
deleted file mode 100644 (file)
index 48cc5ed..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "qca9563_tplink_tl-wpa8630p-v2.dtsi"
-
-/ {
-       compatible = "tplink,tl-wpa8630p-v2-eu", "qca,qca9563";
-       model = "TP-Link WPA8630P v2 (EU)";
-};
-
-&partitions {
-       partition@620000 {
-               label = "partition-table";
-               reg = <0x620000 0x010000>;
-               read-only;
-       };
-
-       info: partition@630000 {
-               label = "info";
-               reg = <0x630000 0x010000>;
-               read-only;
-       };
-
-       partition@640000 {
-               label = "tplink";
-               reg = <0x640000 0x1b0000>;
-               read-only;
-       };
-
-       art: partition@7f0000 {
-               label = "art";
-               reg = <0x7f0000 0x010000>;
-               read-only;
-       };
-};
diff --git a/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630p-v2.0-eu.dts b/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630p-v2.0-eu.dts
new file mode 100644 (file)
index 0000000..9eff2fc
--- /dev/null
@@ -0,0 +1,34 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9563_tplink_tl-wpa8630p-v2.dtsi"
+
+/ {
+       compatible = "tplink,tl-wpa8630p-v2.0-eu", "qca,qca9563";
+       model = "TP-Link WPA8630P v2.0 (EU)";
+};
+
+&partitions {
+       partition@620000 {
+               label = "partition-table";
+               reg = <0x620000 0x010000>;
+               read-only;
+       };
+
+       info: partition@630000 {
+               label = "info";
+               reg = <0x630000 0x010000>;
+               read-only;
+       };
+
+       partition@640000 {
+               label = "tplink";
+               reg = <0x640000 0x1b0000>;
+               read-only;
+       };
+
+       art: partition@7f0000 {
+               label = "art";
+               reg = <0x7f0000 0x010000>;
+               read-only;
+       };
+};
index c812f283af0d6bd058c764685edbe5aa5d2e1ed9..cc5a9305319c9f1c5d1273da926c1a0833835715 100755 (executable)
@@ -323,8 +323,8 @@ tplink,tl-mr6400-v1)
        ucidef_set_led_netdev "4g" "4G" "white:4g" "usb0"
        ;;
 tplink,tl-wpa8630-v1|\
-tplink,tl-wpa8630p-v2-eu|\
 tplink,tl-wpa8630p-v2-int|\
+tplink,tl-wpa8630p-v2.0-eu|\
 tplink,tl-wpa8630p-v2.1-eu)
        ucidef_set_led_switch "lan" "LAN" "green:lan" "switch0" "0x3c"
        ;;
index 58ff2aa6eb039ad0188e9f13d569bfb1ca8a39df..bed817e286b133975578b2b5cf66d6664b0100e2 100755 (executable)
@@ -323,8 +323,8 @@ ath79_setup_interfaces()
                        "0@eth0" "1:lan:1" "2:lan:3" "3:lan:2"
                ;;
        tplink,tl-wpa8630-v1|\
-       tplink,tl-wpa8630p-v2-eu|\
        tplink,tl-wpa8630p-v2-int|\
+       tplink,tl-wpa8630p-v2.0-eu|\
        tplink,tl-wpa8630p-v2.1-eu)
                # port 5 (internal) is the power-line port
                ucidef_add_switch "switch0" \
index 248b436c72296571d18e1f5527768f5ea8bec5b2..857f566db8d3e1c1f15f8f30048971e5f637c7d8 100644 (file)
@@ -197,8 +197,8 @@ case "$FIRMWARE" in
                        /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
                ;;
        tplink,eap225-wall-v2|\
-       tplink,tl-wpa8630p-v2-eu|\
        tplink,tl-wpa8630p-v2-int|\
+       tplink,tl-wpa8630p-v2.0-eu|\
        tplink,tl-wpa8630p-v2.1-eu)
                caldata_extract "art" 0x5000 0x2f20
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary info 0x8) +1)
index a2fbf712db200c294fcad29e1fe3b896dd5a9ecc..7979dda78639a896de29d77b30958a6eaced8bf7 100644 (file)
@@ -550,13 +550,6 @@ define Device/tplink_tl-wpa8630p-v2
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
 endef
 
-define Device/tplink_tl-wpa8630p-v2-eu
-  $(Device/tplink_tl-wpa8630p-v2)
-  DEVICE_VARIANT := v2 (EU)
-  TPLINK_BOARD_ID := TL-WPA8630P-V2-EU
-endef
-TARGET_DEVICES += tplink_tl-wpa8630p-v2-eu
-
 define Device/tplink_tl-wpa8630p-v2-int
   $(Device/tplink_tl-wpa8630p-v2)
   DEVICE_VARIANT := v2 (Int.)
@@ -564,6 +557,14 @@ define Device/tplink_tl-wpa8630p-v2-int
 endef
 TARGET_DEVICES += tplink_tl-wpa8630p-v2-int
 
+define Device/tplink_tl-wpa8630p-v2.0-eu
+  $(Device/tplink_tl-wpa8630p-v2)
+  DEVICE_VARIANT := v2.0 (EU)
+  TPLINK_BOARD_ID := TL-WPA8630P-V2.0-EU
+  SUPPORTED_DEVICES += tplink,tl-wpa8630p-v2-eu
+endef
+TARGET_DEVICES += tplink_tl-wpa8630p-v2.0-eu
+
 define Device/tplink_tl-wpa8630p-v2.1-eu
   $(Device/tplink_tl-wpa8630p-v2)
   DEVICE_VARIANT := v2.1 (EU)
index eececeaf619991ef0939f9b075da22fe81582d1c..31b9c032d1b451c24993c5cbcdef85279b694df5 100644 (file)
@@ -1443,7 +1443,7 @@ static struct device_info boards[] = {
 
        /** Firmware layout for the TL-WPA8630P v2 (EU)*/
        {
-               .id     = "TL-WPA8630P-V2-EU",
+               .id     = "TL-WPA8630P-V2.0-EU",
                .vendor = "",
                .support_list =
                        "SupportList:\n"