Revert "wolfssl: set nonshared flag global"
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Wed, 8 Jun 2022 23:35:45 +0000 (01:35 +0200)
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Wed, 8 Jun 2022 23:35:45 +0000 (01:35 +0200)
This reverts commit e0cc5b9b3ae65113f0e0dd9249dae4776b65c503.
A better and correct solution was found.

Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
package/libs/wolfssl/Makefile

index 7176995ec201e6504e13abb625cb71fa0a8c8102..3edd526364041d646a41c4990c4a765d31882e94 100644 (file)
@@ -48,15 +48,6 @@ PKG_CONFIG_DEPENDS+=\
        CONFIG_WOLFSSL_HAS_DEVCRYPTO_CBC \
        CONFIG_WOLFSSL_HAS_DEVCRYPTO_FULL
 
-#
-# libwolfssl-benchmark should NOT be compiled as nonshared but
-# currently there is a bug where on buildbot stage2 the package
-# is recompiled to build libwolfssl-benchmark and the dependency
-# change to the new libwolfssl version. While this gets
-# investigated, set the nonshared flag global
-#
-PKGFLAGS:=nonshared
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libwolfssl/Default
@@ -69,6 +60,7 @@ endef
 define Package/libwolfssl
 $(call Package/libwolfssl/Default)
   TITLE:=wolfSSL library
+  PKGFLAGS:=nonshared
   MENU:=1
   PROVIDES:=libcyassl
   DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user