Added raddump
authorFlorian Fainelli <florian@openwrt.org>
Tue, 13 Dec 2005 13:38:59 +0000 (13:38 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 13 Dec 2005 13:38:59 +0000 (13:38 +0000)
SVN-Revision: 2650

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/raddump/Config.in [new file with mode: 0755]
openwrt/package/raddump/Makefile [new file with mode: 0755]
openwrt/package/raddump/ipkg/raddump.control [new file with mode: 0755]

index ad53b4aff5840230946e1b036820c87cced3e7c3..4342107e52d8d0b706fd5c065d5d4f07b2efe29b 100644 (file)
@@ -105,6 +105,7 @@ source "package/rp-pppoe/Config.in"
 source "package/pptp/Config.in"
 source "package/pptpd/Config.in"
 source "package/quagga/Config.in"
+source "package/raddump/Config.in"
 source "package/rarpd/Config.in"
 source "package/reaim/Config.in"
 source "package/robocfg/Config.in"
index 358e1d6c9679240a0431aa0174c16102e00ebe6f..e273949fdab759934fd7c75382ee9083f5c4a371 100644 (file)
@@ -297,6 +297,7 @@ portmap-compile: tcp_wrappers-compile
 postgresql-compile: zlib-compile
 ppp-compile: linux-atm-compile
 quagga-compile: readline-compile ncurses-compile
+raddump-compile: openssl-compile libpcap-compile
 rarpd-compile: libnet-compile
 ifneq ($(BR2_PACKAGE_LIBRRD),)
 rrdcollect-compile: rrdtool-compile
diff --git a/openwrt/package/raddump/Config.in b/openwrt/package/raddump/Config.in
new file mode 100755 (executable)
index 0000000..bacafe3
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_RADDUMP
+        tristate "raddump........................... raddump interprets captured RADIUS packets."
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBOPENSSL
+       select BR2_PACKAGE_LIBPCAP
+       help
+               raddump interprets captured RADIUS packets to print a timestamp, packet length, RADIUS packet type, 
+               source and destination hosts and ports, and included attribute names and values for each packet.
diff --git a/openwrt/package/raddump/Makefile b/openwrt/package/raddump/Makefile
new file mode 100755 (executable)
index 0000000..f8132c4
--- /dev/null
@@ -0,0 +1,53 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=raddump
+PKG_VERSION:=0.3.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=f8c29c67141ea78bb6ae8b97d5149480
+PKG_SOURCE_URL:=@SF/raddump
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,RADDUMP,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(TARGET_CFLAGS)" \
+                ./configure \
+                ac_cv_c_bigendian=no \
+                ac_cv_func_malloc_0_nonnull=yes \
+                ac_cv_func_realloc_0_nonnull=yes \
+                $(DISABLE_NLS) \
+                --target=$(GNU_TARGET_NAME) \
+                --host=$(GNU_TARGET_NAME) \
+                --build=$(GNU_HOST_NAME) \
+                --prefix=/usr \
+                --exec-prefix=/usr \
+                --bindir=/usr/bin \
+                --sbindir=/usr/sbin \
+                --libexecdir=/usr/lib \
+                --sysconfdir=/etc \
+                --datadir=/usr/share \
+                --localstatedir=/var \
+               --mandir=/usr/man \
+                --infodir=/usr/info \
+                --program-prefix="" \
+               --with-gnu-ld \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+       touch $@
+
+$(IPKG_RADDUMP):
+       mkdir -p $(IDIR_RADDUMP)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_RADDUMP)/
+       $(RSTRIP) $(IDIR_RADDUMP)
+       $(IPKG_BUILD) $(IDIR_RADDUMP) $(PACKAGE_DIR)
diff --git a/openwrt/package/raddump/ipkg/raddump.control b/openwrt/package/raddump/ipkg/raddump.control
new file mode 100755 (executable)
index 0000000..2d31b02
--- /dev/null
@@ -0,0 +1,6 @@
+Package: raddump 
+Depends: libpcap, libopenssl
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: raddump interprets captured RADIUS packets to print a timestamp, packet length, RADIUS packet type, source and destination hosts and ports, and included attribute names and values for each packet.