build the kmod-video-quickcam module only if it was selected
authorNicolas Thill <nico@openwrt.org>
Sun, 20 Apr 2008 09:49:13 +0000 (09:49 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 20 Apr 2008 09:49:13 +0000 (09:49 +0000)
SVN-Revision: 10881

package/qc-usb/Makefile

index 1d57ccb664823e52ebbdfc8e7ca56d49cfa95116..8fd666809a96ef836d76a219128eee6e4dbf9065 100644 (file)
@@ -58,7 +58,8 @@ ifeq ($(KERNEL),2.4)
   endif
 endif
 
-define Build/Compile
+ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
+  define Build/Compile/kmod
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LINUX_DIR="$(LINUX_DIR)" \
                ARCH="$(LINUX_KARCH)" \
@@ -67,11 +68,20 @@ define Build/Compile
                LD="$(TARGET_CC) -nodefaultlibs -nostartfiles" \
                USER_OPT="$(KERNEL_C_OPTS)" \
                quickcam.$(LINUX_KMOD_SUFFIX)
+  endef
+endif
+
+define Build/Compile/user
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CFLAGS="$(TARGET_CFLAGS)" \
                qcset
 endef
 
+define Build/Compile
+       $(call Build/Compile/kmod)
+       $(call Build/Compile/user)
+endef
+
 define Package/qc-usb-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/qcset $(1)/usr/bin/