Also generate http uploadable images for Airlink AR525w
authorFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2008 14:11:01 +0000 (14:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2008 14:11:01 +0000 (14:11 +0000)
SVN-Revision: 10229

target/linux/rdc/image/Makefile

index 4d8c5fda339d064a312a2456ae09b9c946818766..613aa3923d657032b6fefd89aaa3a7b0329cb9e7 100644 (file)
@@ -23,10 +23,12 @@ endef
 
 define Image/Build/ar525w
        touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
        mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
        dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
        $(RM) $(KDIR)/root.tmp
        $(STAGING_DIR_HOST)/bin/airlink -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       $(STAGING_DIR_HOST)/bin/airlink -e -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
 endef
 
 define Image/Build/wl153