download.mk: fix packed checkout mirroring support
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Feb 2016 08:44:37 +0000 (08:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Feb 2016 08:44:37 +0000 (08:44 +0000)
Changeset r48416  broke the downloading of mirrored, packed scm checkouts.

Fix this by removing the "@" sign in front of the download command which is
now executed as part of a larger shell command under flock.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 48733

include/download.mk

index 8619734d17e5be60d4c58cf33c57dc00a174769c..988542f95aca7bf533341ca20988259ef0f01a8e 100644 (file)
@@ -48,7 +48,7 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       $(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" "" || ( $(1) ),$(1))
+$(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" "" || ( $(1) ),$(1))
 endef
 
 define DownloadMethod/cvs