package xfce-macros, required for autoreconf in xfce4 packages
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Mar 2011 14:44:23 +0000 (14:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Mar 2011 14:44:23 +0000 (14:44 +0000)
SVN-Revision: 25974

tools/Makefile
tools/xfce-macros/Makefile [new file with mode: 0644]

index 6479162c50968909c94e88c498137bf4d97e6bdb..149e3cea83625baa527fbaa516b729b3c76ddaac 100644 (file)
@@ -17,7 +17,7 @@ endif
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += mm-macros xorg-macros missing-macros xz cmake
+tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
@@ -54,6 +54,7 @@ $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
 $(curdir)/mm-macros/compile := $(curdir)/automake/install
 $(curdir)/xorg-macros/compile := $(curdir)/automake/install
+$(curdir)/xfce-macros/compile := $(curdir)/automake/install
 $(curdir)/missing-macros/compile := $(curdir)/automake/install
 $(curdir)/e2fsprogs/compile := $(curdir)/automake/install
 $(curdir)/libelf/compile := $(curdir)/automake/install
diff --git a/tools/xfce-macros/Makefile b/tools/xfce-macros/Makefile
new file mode 100644 (file)
index 0000000..bd71913
--- /dev/null
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xfce-macros
+PKG_VERSION:=4.8.0
+
+PKG_SOURCE_URL:=http://archive.xfce.org/xfce/4.8/src
+PKG_SOURCE:=xfce4-dev-tools-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=9591299c49d92d00ba47974c42a735fa
+
+HOST_BUILD_DIR:=$(BUILD_DIR)/xfce4-dev-tools-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+       $(INSTALL_DATA) $(HOST_BUILD_DIR)/m4macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+$(eval $(call HostBuild))