kernel: Update kernel 4.9 to version 4.9.240
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 16 Oct 2020 20:16:07 +0000 (22:16 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Oct 2020 22:32:15 +0000 (00:32 +0200)
Compile and runtime tested on ar71xx/generic.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
25 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/403-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ar71xx/patches-4.9/411-mtd-cfi_cmdset_0002-force-word-write.patch
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/generic/backport-4.9/030-01-ubifs-Drop-softlimit-and-delta-fields-from-struct-ub.patch
target/linux/generic/backport-4.9/030-02-ubifs-Use-dirty_writeback_interval-value-for-wbuf-ti.patch
target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch
target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch
target/linux/generic/backport-4.9/042-mm-rename-__page_frag-functions-to-__page_frag_cache.patch
target/linux/generic/backport-4.9/075-v4.10-0004-net-phy-broadcom-Add-BCM54810-PHY-entry.patch
target/linux/generic/hack-4.9/700-swconfig_switch_drivers.patch
target/linux/generic/hack-4.9/702-phy_add_aneg_done_function.patch
target/linux/generic/hack-4.9/710-phy-add-mdio_register_board_info.patch
target/linux/generic/hack-4.9/721-phy_packets.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/generic/pending-4.9/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
target/linux/generic/pending-4.9/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch
target/linux/generic/pending-4.9/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch
target/linux/generic/pending-4.9/630-packet_socket_type.patch
target/linux/generic/pending-4.9/655-increase_skb_pad.patch
target/linux/generic/pending-4.9/834-ledtrig-libata.patch
target/linux/ixp4xx/patches-4.9/160-delayed_uart_io.patch
target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
target/linux/layerscape/patches-4.9/703-phy-support-layerscape.patch
target/linux/uml/patches-4.9/101-mconsole-exec.patch

index db29e2165bc2b7ac079c408004162b6b2c6ab69f..a4532b764e6f768ee8c600335d8ce1b28d53ee13 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .237
+LINUX_VERSION-4.9 = .240
 LINUX_VERSION-4.14 = .199
 
-LINUX_KERNEL_HASH-4.9.237 = 81ec5792c0ccdc244faff9dbb3d9c97857d9df4cb1f0c1c3db6bc4031faf861f
+LINUX_KERNEL_HASH-4.9.240 = 06e470c66988da200ae95dc5d5fdfd1e1f8611e8c3445620e3566ecd0bdf776f
 LINUX_KERNEL_HASH-4.14.199 = 02f3432a262b3804745501f8c3c51d735133af48a39909df8b031d0b9653d4f9
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 5fc15589b8018c95038febfb21181211c724813a..09d0d129e823a94b2ec186af007f1dbd3ad9d079 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1637,7 +1637,7 @@ static int __xipram do_write_oneword(str
+@@ -1636,7 +1636,7 @@ static int __xipram do_write_oneword(str
                }
  
                if (chip_good(map, adr, datum))
@@ -9,7 +9,7 @@
  
                /* Latency issues. Drop the lock, wait a while and retry */
                UDELAY(map, chip, adr, 1);
-@@ -1654,6 +1654,8 @@ static int __xipram do_write_oneword(str
+@@ -1653,6 +1653,8 @@ static int __xipram do_write_oneword(str
                        goto retry;
                }
        }
@@ -18,7 +18,7 @@
        xip_enable(map, chip, adr);
   op_done:
        if (mode == FL_OTP_WRITE)
-@@ -2236,7 +2238,6 @@ static int cfi_amdstd_panic_write(struct
+@@ -2235,7 +2237,6 @@ static int cfi_amdstd_panic_write(struct
        return 0;
  }
  
@@ -26,7 +26,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -2304,7 +2305,7 @@ static int __xipram do_erase_chip(struct
+@@ -2303,7 +2304,7 @@ static int __xipram do_erase_chip(struct
                }
  
                if (chip_good(map, adr, map_word_ff(map)))
@@ -35,7 +35,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2328,6 +2329,7 @@ static int __xipram do_erase_chip(struct
+@@ -2327,6 +2328,7 @@ static int __xipram do_erase_chip(struct
                }
        }
  
@@ -43,7 +43,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        DISABLE_VPP(map);
-@@ -2401,7 +2403,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2400,7 +2402,7 @@ static int __xipram do_erase_oneblock(st
  
                if (chip_good(map, adr, map_word_ff(map))) {
                        xip_enable(map, chip, adr);
@@ -52,7 +52,7 @@
                }
  
                if (time_after(jiffies, timeo)) {
-@@ -2427,6 +2429,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2426,6 +2428,7 @@ static int __xipram do_erase_oneblock(st
                }
        }
  
index 7b375ab0fa0aed9c4b117a3ddab4aa2089be5b35..84fba8b7d7f3a4397737675ea49512c2592fec53 100644 (file)
@@ -35,7 +35,7 @@
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd)
-@@ -1796,6 +1800,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1795,6 +1799,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -43,7 +43,7 @@
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1928,7 +1933,6 @@ static int __xipram do_write_buffer(stru
+@@ -1927,7 +1932,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -51,7 +51,7 @@
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -2003,6 +2007,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2002,6 +2006,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }
index 0fdf86af8a2b4a716aa106a16ebf12d78ecda43c..de2417da96065c567627b744d1e4ce1c7e7e0412 100644 (file)
        for (p = *head; p; p = p->next) {
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -459,7 +459,7 @@ static struct neighbour *ipv4_neigh_look
+@@ -460,7 +460,7 @@ static struct neighbour *ipv4_neigh_look
        else if (skb)
                pkey = &ip_hdr(skb)->daddr;
  
index 8e1f312a0b56e8f7fe9e064049d1303846d4e34f..c1367074bd0c7bdcfdfb29f6346471948734e72d 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
 
 --- a/fs/ubifs/io.c
 +++ b/fs/ubifs/io.c
-@@ -452,16 +452,22 @@ static enum hrtimer_restart wbuf_timer_c
+@@ -464,16 +464,22 @@ static enum hrtimer_restart wbuf_timer_c
   */
  static void new_wbuf_timer_nolock(struct ubifs_wbuf *wbuf)
  {
@@ -48,7 +48,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
                               HRTIMER_MODE_REL);
  }
  
-@@ -1059,10 +1065,6 @@ int ubifs_wbuf_init(struct ubifs_info *c
+@@ -1071,10 +1077,6 @@ int ubifs_wbuf_init(struct ubifs_info *c
  
        hrtimer_init(&wbuf->timer, CLOCK_MONOTONIC, HRTIMER_MODE_REL);
        wbuf->timer.function = wbuf_timer_callback_nolock;
index 96fa44113202e8c432356f75b77be137a7119d17..9ddaf897308754d1e1cab43cb9baded1caf2f6f9 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
 
 --- a/fs/ubifs/io.c
 +++ b/fs/ubifs/io.c
-@@ -452,11 +452,11 @@ static enum hrtimer_restart wbuf_timer_c
+@@ -464,11 +464,11 @@ static enum hrtimer_restart wbuf_timer_c
   */
  static void new_wbuf_timer_nolock(struct ubifs_wbuf *wbuf)
  {
index f79bda0de20e5ddf03b675eb75e65355647086d2..b5c57069e37dce3266c3cf2f4ba04778872e6526 100644 (file)
@@ -52,7 +52,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  extern void __free_page_frag(void *addr);
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -3941,6 +3941,20 @@ static struct page *__page_frag_refill(s
+@@ -3942,6 +3942,20 @@ static struct page *__page_frag_refill(s
        return page;
  }
  
index e646efd6406440b50e67ec43e1301e1d76684554..d27bf9405798e8dbae6855880f7fe14dcc52d668 100644 (file)
@@ -52,7 +52,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  #define free_page(addr) free_pages((addr), 0)
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2477,7 +2477,7 @@ static inline struct sk_buff *netdev_all
+@@ -2489,7 +2489,7 @@ static inline struct sk_buff *netdev_all
  
  static inline void skb_free_frag(void *addr)
  {
@@ -63,7 +63,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  void *napi_alloc_frag(unsigned int fragsz);
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -3955,8 +3955,8 @@ void __page_frag_drain(struct page *page
+@@ -3956,8 +3956,8 @@ void __page_frag_drain(struct page *page
  }
  EXPORT_SYMBOL(__page_frag_drain);
  
@@ -74,7 +74,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  {
        unsigned int size = PAGE_SIZE;
        struct page *page;
-@@ -4007,19 +4007,19 @@ refill:
+@@ -4008,19 +4008,19 @@ refill:
  
        return nc->va + offset;
  }
index bb49c53223008602485f20baa67684e8b58cb9a9..a49eb10478168af70a2d323f604bf4d38780a72f 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  extern void page_frag_free(void *addr);
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -3920,8 +3920,8 @@ EXPORT_SYMBOL(free_pages);
+@@ -3921,8 +3921,8 @@ EXPORT_SYMBOL(free_pages);
   * drivers to provide a backing region of memory for use as either an
   * sk_buff->head, or to be used in the "frags" portion of skb_shared_info.
   */
@@ -44,7 +44,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  {
        struct page *page = NULL;
        gfp_t gfp = gfp_mask;
-@@ -3941,19 +3941,20 @@ static struct page *__page_frag_refill(s
+@@ -3942,19 +3942,20 @@ static struct page *__page_frag_refill(s
        return page;
  }
  
@@ -68,7 +68,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  
  void *page_frag_alloc(struct page_frag_cache *nc,
                      unsigned int fragsz, gfp_t gfp_mask)
-@@ -3964,7 +3965,7 @@ void *page_frag_alloc(struct page_frag_c
+@@ -3965,7 +3966,7 @@ void *page_frag_alloc(struct page_frag_c
  
        if (unlikely(!nc->va)) {
  refill:
index 3d61ec63694a3bbed0e02c3292d4303e5c8c576e..34d86e66440db0746ca8dff54513a7bee2371f0f 100644 (file)
@@ -126,7 +126,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        { PHY_ID_BCM50610M, 0xfffffff0 },
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -204,7 +204,7 @@ config BROADCOM_PHY
+@@ -205,7 +205,7 @@ config BROADCOM_PHY
        select BCM_NET_PHYLIB
        ---help---
          Currently supports the BCM5411, BCM5421, BCM5461, BCM54616S, BCM5464,
index 760ba4fc800928e1f2c4778c687644c289152955..57c25ddbf1296512074a6b17fd2cd4dcbdd4d337 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -147,6 +147,89 @@ config MDIO_XGENE
+@@ -148,6 +148,89 @@ config MDIO_XGENE
          This module provides a driver for the MDIO busses found in the
          APM X-Gene SoC's.
  
index ab8b8647ecf75862070f995bfc4a12c91ce0282e..32bd9ce4dcb0299342e4b0e17e0cd4be51dfddd7 100644 (file)
@@ -15,7 +15,7 @@
  
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1320,6 +1320,9 @@ int genphy_update_link(struct phy_device
+@@ -1321,6 +1321,9 @@ int genphy_update_link(struct phy_device
  {
        int status;
  
index e25c517ea75a2e90a3ee04fcbba779ce075d62d4..dfedffe9ebdaa485015d9f01be7ffa02dff594f0 100644 (file)
@@ -76,7 +76,7 @@
   * @__phy_drivers: array of PHY drivers to register
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -149,6 +149,10 @@ config MDIO_XGENE
+@@ -150,6 +150,10 @@ config MDIO_XGENE
  
  comment "Switch configuration API + drivers"
  
index ed51c22b94418cd739d38c74758ecd5bcb8eba8c..3b9a21cdd6a0f96449f55bc102e4c0482c2abc37 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2340,6 +2340,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2352,6 +2352,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2460,16 +2464,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2472,16 +2476,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
index b6555ca9de00c753833f78f76ebb966be481a2f6..b7555286404a2f909bd4075aec9d7e505060df10 100644 (file)
@@ -394,7 +394,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -421,6 +421,9 @@ static struct pernet_operations ip_rt_pr
+@@ -422,6 +422,9 @@ static struct pernet_operations ip_rt_pr
  
  static int __init ip_rt_proc_init(void)
  {
index d53e331877969b43d1377e0f20eea54356fee954..5b886b30fda2b44e3a3892837361ff41df28f668 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -5931,7 +5931,7 @@ static void __ref alloc_node_mem_map(str
+@@ -5932,7 +5932,7 @@ static void __ref alloc_node_mem_map(str
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
index c52d7de76251cf5c56df389555fe0cdad203725d..74cded8de889d24917864abb24eb97900f2677ec 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -807,7 +807,7 @@ static int get_chip(struct map_info *map
+@@ -806,7 +806,7 @@ static int get_chip(struct map_info *map
                return 0;
  
        case FL_ERASING:
index f78667994c14c5ad969f954354266dfddaf89bda..c2d6185cd809a94fb9c364ea9ae139bf1108f378 100644 (file)
@@ -7,7 +7,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  1 file changed, 1 insertion(+)
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1835,6 +1835,7 @@ static int __xipram do_write_buffer(stru
+@@ -1834,6 +1834,7 @@ static int __xipram do_write_buffer(stru
  
        /* Write Buffer Load */
        map_write(map, CMD(0x25), cmd_adr);
index c47bc371c826d48a598dcd63d0f83930031662a1..158c6101c6e38c7294d33927d00682b574f7e5c1 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2175,12 +2177,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -2176,12 +2178,12 @@ static int tpacket_rcv(struct sk_buff *s
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
  
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3298,6 +3300,7 @@ static int packet_create(struct net *net
+@@ -3305,6 +3307,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3920,6 +3923,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3927,6 +3930,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3972,6 +3985,13 @@ static int packet_getsockopt(struct sock
+@@ -3979,6 +3992,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index 87f9bb6a95e0abebe79877e4f12043f3958516f9..f5babbe4ecf94f7dfc3a8f4f6b3a7118fd8fa881 100644 (file)
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2304,7 +2304,7 @@ static inline int pskb_network_may_pull(
+@@ -2316,7 +2316,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index 062e9fac72d58fa2e73161cd2207db23b18edba4..cde478f3bb78b7dcb5eade116ac6f59cc1319899 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4996,6 +5009,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4999,6 +5012,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -5897,6 +5913,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5902,6 +5918,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5918,6 +5937,12 @@ static void ata_host_release(struct devi
+@@ -5923,6 +5942,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6364,7 +6389,23 @@ int ata_host_register(struct ata_host *h
+@@ -6369,7 +6394,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -134,7 +134,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -888,6 +891,12 @@ struct ata_port {
+@@ -889,6 +892,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index 41a7c06b16228aedf4fb8a4992ac934f1cf105a2..7565901ac411eb8f3634d26193fdfa81eb24b5f1 100644 (file)
        case UPIO_AU:
                p->serial_out(p, offset, value);
                p->serial_in(p, UART_LCR);      /* safe, no side-effects */
-@@ -2766,6 +2786,7 @@ static int serial8250_request_std_resour
+@@ -2780,6 +2800,7 @@ static int serial8250_request_std_resour
        case UPIO_MEM32BE:
        case UPIO_MEM16:
        case UPIO_MEM:
                if (!port->mapbase)
                        break;
  
-@@ -2804,6 +2825,7 @@ static void serial8250_release_std_resou
+@@ -2818,6 +2839,7 @@ static void serial8250_release_std_resou
        case UPIO_MEM32BE:
        case UPIO_MEM16:
        case UPIO_MEM:
index 14e08b291bb9f0e708672feb55afbbed03faca84..82f5e19bf5a357ce1ae5c221c3c55124d711e17a 100644 (file)
@@ -384,7 +384,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  void  __kfree_skb(struct sk_buff *skb);
  extern struct kmem_cache *skbuff_head_cache;
  
-@@ -3083,6 +3084,7 @@ static inline void skb_free_datagram_loc
+@@ -3095,6 +3096,7 @@ static inline void skb_free_datagram_loc
  }
  int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
  int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
index a26b1b526de4e589c0ccfea80a5568b7044d248c..97f91e86433b7315ff209332db14c2fee8862b31 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  config MDIO_GPIO
        tristate "GPIO lib-based bitbanged MDIO buses"
        depends on MDIO_BITBANG && GPIOLIB
-@@ -298,6 +304,11 @@ config CICADA_PHY
+@@ -299,6 +305,11 @@ config CICADA_PHY
        ---help---
          Currently supports the cis8204
  
@@ -1695,7 +1695,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  EXPORT_SYMBOL(phy_ethtool_get_wol);
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1054,7 +1054,7 @@ int phy_suspend(struct phy_device *phyde
+@@ -1055,7 +1055,7 @@ int phy_suspend(struct phy_device *phyde
        if (wol.wolopts)
                return -EBUSY;
  
@@ -1704,7 +1704,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                ret = phydrv->suspend(phydev);
  
        if (ret)
-@@ -1071,7 +1071,7 @@ int phy_resume(struct phy_device *phydev
+@@ -1072,7 +1072,7 @@ int phy_resume(struct phy_device *phydev
        struct phy_driver *phydrv = to_phy_driver(phydev->mdio.dev.driver);
        int ret = 0;
  
@@ -1713,7 +1713,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                ret = phydrv->resume(phydev);
  
        if (ret)
-@@ -1728,7 +1728,7 @@ static int phy_remove(struct device *dev
+@@ -1729,7 +1729,7 @@ static int phy_remove(struct device *dev
        phydev->state = PHY_DOWN;
        mutex_unlock(&phydev->lock);
  
index ea9da8d8c3d12b142bf2949810935d715cf99292..4f88e30b4150f0201437736d9e479a146454f12d 100644 (file)
  #endif /* __LINUX_KMOD_H__ */
 --- a/kernel/kmod.c
 +++ b/kernel/kmod.c
-@@ -39,6 +39,7 @@
+@@ -40,6 +40,7 @@
  #include <linux/rwsem.h>
  #include <linux/ptrace.h>
  #include <linux/async.h>
  #include <asm/uaccess.h>
  
  #include <trace/events/module.h>
-@@ -222,6 +223,28 @@ static int call_usermodehelper_exec_asyn
+@@ -223,6 +224,28 @@ static int call_usermodehelper_exec_asyn
        flush_signal_handlers(current, 1);
        spin_unlock_irq(&current->sighand->siglock);
  
 +      }
 +
        /*
-        * Our parent (unbound workqueue) runs with elevated scheduling
-        * priority. Avoid propagating that into the userspace child.
-@@ -540,6 +563,20 @@ struct subprocess_info *call_usermodehel
+        * Initial kernel threads share ther FS with init, in order to
+        * get the init root directory. But we've now created a new
+@@ -549,6 +572,20 @@ struct subprocess_info *call_usermodehel
  }
  EXPORT_SYMBOL(call_usermodehelper_setup);