valgrind: enable LTO and refresh patches
authorSyrone Wong <wong.syrone@gmail.com>
Sat, 24 Nov 2018 02:00:46 +0000 (10:00 +0800)
committerJohn Crispin <john@phrozen.org>
Mon, 26 Nov 2018 08:44:42 +0000 (09:44 +0100)
Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
package/devel/valgrind/Makefile
package/devel/valgrind/patches/100-fix_configure_check.patch
package/devel/valgrind/patches/130-fix_arm_arch_detection.patch

index d3844c238868556433802b71992f510ed464f5bb..a670ba51b593597fd2b6f7b670eda0c090ab570d 100644 (file)
@@ -105,6 +105,7 @@ CONFIGURE_ARGS += \
        --disable-valgrindtk \
        --without-included-gettext \
        --with-pagesize=4 \
+       --enable-lto
 
 define Package/valgrind/install        
        $(INSTALL_DIR) $(1)/usr/bin
index 6ba5fdf1d7272231dd60360dca6c26f641154461..270181ae376a2eb6f74d2f412ea6125b95cac3dc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -323,7 +323,7 @@ case "${host_os}" in
+@@ -341,7 +341,7 @@ case "${host_os}" in
          # Ok, this is linux. Check the kernel version
          AC_MSG_CHECKING([for the kernel version])
  
index c8d203390c8344148f07509006330278dff79639..26291f777bb7b7c4cbbf673f74701bde8edcbe09 100644 (file)
@@ -6,7 +6,7 @@ Last-Update: 2013-11-30
 
 --- a/configure.ac
 +++ b/configure.ac
-@@ -234,7 +234,7 @@ case "${host_cpu}" in
+@@ -252,7 +252,7 @@ case "${host_cpu}" in
          ARCH_MAX="s390x"
          ;;