perf: simplify the build process
authorPetr Štetiar <ynezz@true.cz>
Tue, 16 Jul 2019 19:43:08 +0000 (21:43 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 17 Jul 2019 10:16:29 +0000 (12:16 +0200)
Redirect the build output to PKG_BUILD_DIR instead of copying over
complete source code.

Build tested on following targets:

 x86/64 ar7/generic ipq40xx/generic imx6/generic ar71xx/generic
 ramips/mt7621 ramips/mt7620 sunxi/cortexa7

Run tested on imx6/apalis.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/devel/perf/Makefile

index 3d7110585cca9630b6dd321f21fb929a1989554f..6f31c826e5780ec02b70b026185c37568147cb98 100644 (file)
@@ -36,10 +36,6 @@ define Package/perf/description
   perf is the Linux performance monitoring tool
 endef
 
-define Build/Prepare
-       $(CP) $(LINUX_DIR)/tools/perf/* $(PKG_BUILD_DIR)/
-endef
-
 MAKE_FLAGS = \
        ARCH="$(LINUX_KARCH)" \
        NO_LIBPERL=1 \
@@ -59,13 +55,13 @@ MAKE_FLAGS = \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
        WERROR=0 \
+       O=$(PKG_BUILD_DIR) \
        prefix=/usr
 
 define Build/Compile
        +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
-               -C $(PKG_BUILD_DIR) \
-               -f Makefile.perf \
-               --no-print-directory
+               --no-print-directory \
+               -C $(LINUX_DIR)/tools/perf
 endef
 
 define Package/perf/install