kernel: bump 4.19 to 4.19.53
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 20 Jun 2019 09:10:18 +0000 (11:10 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 20 Jun 2019 13:48:48 +0000 (15:48 +0200)
Refreshed all patches.

Compile-tested on: imx6
Runtime-tested on: imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.19/930-crashlog.patch
target/linux/generic/pending-4.19/834-ledtrig-libata.patch

index 931fe571c7341b4f8689f49063c50aa651298554..cadfd5471c0dc5f7ebbee0bf13d9765705b57f74 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .182
 LINUX_VERSION-4.14 = .128
-LINUX_VERSION-4.19 = .52
+LINUX_VERSION-4.19 = .53
 
 LINUX_KERNEL_HASH-4.9.182 = b16e12681a0638368479d73a9b1b8e9407c1ae4b7ae52fdf236d9e5657999695
 LINUX_KERNEL_HASH-4.14.128 = e93c2c754f1f9c610314b2fe9f27a9636ad3a7f43983469bb8e0f44a531f2913
-LINUX_KERNEL_HASH-4.19.52 = 266ee655620c3689ae94761970d6827fffc919760caf815427ad22730ba4381e
+LINUX_KERNEL_HASH-4.19.53 = e647730b7eafac70c3bd7abed4e6ed5a09eb794c645fcb0c62a79f62edbdeb02
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 890c72b640da5132ae8605b980f0f377e2093e79..0088b7a081ef84941a3155d0b75ee2d6adc08a0d 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
-@@ -116,6 +116,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
+@@ -117,6 +117,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
  obj-$(CONFIG_HAS_IOMEM) += iomem.o
  obj-$(CONFIG_ZONE_DEVICE) += memremap.o
  obj-$(CONFIG_RSEQ) += rseq.o
index 70d3de05d0eeee26ac81d71ac5f0a94741bc1958..de029fafe5a677aefee767713712a1ecb35d031b 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5131,6 +5144,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5134,6 +5147,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = qc->hw_tag = tag;
-@@ -6041,6 +6057,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6044,6 +6060,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6076,6 +6095,12 @@ static void ata_host_release(struct kref
+@@ -6079,6 +6098,12 @@ static void ata_host_release(struct kref
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6539,7 +6564,23 @@ int ata_host_register(struct ata_host *h
+@@ -6542,7 +6567,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }