procd: start additional consoles during hotplugging
authorMichael Heimpold <mhei@heimpold.de>
Mon, 4 Nov 2019 23:39:40 +0000 (00:39 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Sat, 9 Nov 2019 11:56:30 +0000 (12:56 +0100)
Now that 'start-console' procd command has reached the main repo,
we can add a rule to start consoles on serial devices which are
created when USB gadget driver reports creation with hotplugging.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
package/system/procd/Makefile
package/system/procd/files/hotplug.json

index 8090b87dd5971792e26b725fbe4c6f87cbe1c08d..c4b86ba746249dddc6be7dd0a544fe3a9bc4e17e 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
index f676bac79e43c00bbf3e731cb7a156dec2ffbd31..7e0f129d356515c15fd43cd0c540d5cdc6ecf259 100644 (file)
                                        [ "load-firmware", "/lib/firmware" ],
                                        [ "return" ]
                                ]
+                       ],
+                       [ "if",
+                               [ "regex", "DEVNAME", "^ttyGS" ],
+                               [ "start-console", "%DEVNAME%" ]
                        ]
                ],
                "remove" : [