ramips: bdcom-wap2100: Enable mt7610e 5GHz radio
authorPetr Štetiar <ynezz@true.cz>
Wed, 28 Nov 2018 20:53:02 +0000 (21:53 +0100)
committerMathias Kresin <dev@kresin.me>
Wed, 28 Nov 2018 22:37:29 +0000 (23:37 +0100)
The 5GHz radio of this device uses an mt7610e PCI-E chip, which has
been recently started to be supported.

 mt76x0e 0000:01:00.0: card - bus=0x1, slot = 0x0 irq=4
 mt76x0e 0000:01:00.0: ASIC revision: 76100002
 mt76x0e 0000:01:00.0: Firmware Version: 0.1.00
 mt76x0e 0000:01:00.0: EEPROM ver:01 fae:00

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/dts/BDCOM-WAP2100-SK.dts
target/linux/ramips/image/mt7620.mk

index a417c5147046cc5631f10d5f934d7ded4a163e3a..6747f97ca19ec0272bc396ba0959bd8f01eed223 100644 (file)
        ralink,mtd-eeprom = <&factory 0>;
 };
 
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
 &pinctrl {
        state_default: pinctrl0 {
                default {
index a7aeaf130cc96db1f4ac4fa8cfdc26e4054a4050..886ed62a3deee17cb26a02e0ab4e2eb4f42def8b 100644 (file)
@@ -84,7 +84,7 @@ define Device/bdcom_wap2100-sk
   DTS := BDCOM-WAP2100-SK
   IMAGE_SIZE := 15808k
   DEVICE_TITLE := BDCOM WAP2100-SK (ZTE ZXECS EBG3130)
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76x2 kmod-mt76x0e kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += bdcom_wap2100-sk