procd: allow passing optional syslog facility as instance parameter
authorMichael Heimpold <mhei@heimpold.de>
Thu, 11 Apr 2019 19:01:08 +0000 (21:01 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 2 May 2019 15:38:51 +0000 (17:38 +0200)
Optional syslog facility can be set by adding procd_set_param facility
$myfacility.
While at, also add stdout/stderr documentation.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_SOURCE_VERSION update]
package/system/procd/Makefile
package/system/procd/files/procd.sh

index c6d1b05ca0006e2557822be53a134bcdebee5ba4..f31c8d0cea9bc4c57943d2b745e2023901524d0b 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
-PKG_SOURCE_DATE:=2019-04-26
-PKG_SOURCE_VERSION:=cfaed5630cdef2c1bf58bf57859ce36c62ad0905
-PKG_MIRROR_HASH:=2271f0dd3bd3b3a4a8261aa5017d4d384d37521974a8f7495e17559f16a59cac
+PKG_SOURCE_DATE:=2019-05-02
+PKG_SOURCE_VERSION:=61a8be6cb4423dde9c7e7262456f4a16752b9abc
+PKG_MIRROR_HASH:=6020e59d1a2983a5039e10fd1f5e7b89f229fefecdff9472729709fccc7cdf43
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0
index 72f25fe0c05bd284ee025d32c6aee09c1e4c074a..6115f0702f6bfbf0dfc9977bd3569aee0f7a8145 100644 (file)
@@ -20,6 +20,9 @@
 #     limits: resource limits (passed to the process)
 #     user info: array with 1 values $username
 #     pidfile: file name to write pid into
+#     stdout: boolean whether to redirect commands stdout to syslog (default: 0)
+#     stderr: boolean whether to redirect commands stderr to syslog (default: 0)
+#     facility: syslog facility used when logging to syslog (default: daemon)
 #
 #   No space separation is done for arrays/tables - use one function argument per command line argument
 #
@@ -249,7 +252,7 @@ _procd_set_param() {
                reload_signal)
                        json_add_int "$type" $(kill -l "$1")
                ;;
-               pidfile|user|seccomp|capabilities)
+               pidfile|user|seccomp|capabilities|facility)
                        json_add_string "$type" "$1"
                ;;
                stdout|stderr|no_new_privs)