ramips: move "elx-header" to Makefile from mt7620.mk and mt7621.mk
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Mon, 19 Aug 2019 12:38:24 +0000 (21:38 +0900)
committerChuanhong Guo <gch981213@gmail.com>
Wed, 25 Sep 2019 06:44:36 +0000 (14:44 +0800)
I-O DATA WNPR2600G has an "elx-header", so move this definition to
generic makefile to use it from mt7621 subtarget.
This definition is also added to mt7621.mk in
f285e8634c57d28aa970b80c5c59e85485f35c7d, so remove it from mt7621.mk.

And added a line to cleanup used header file.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt7621.mk

index 816146ece55e2ec8dc9e12dc8c999aa31c416a63..16748b826070ea91ba7853f81ced008e286f63d5 100644 (file)
@@ -89,6 +89,26 @@ define Build/relocate-kernel
        rm -rf $@.relocate
 endef
 
+define Build/elx-header
+       $(eval hw_id=$(word 1,$(1)))
+       $(eval xor_pattern=$(word 2,$(1)))
+       ( \
+               echo -ne "\x00\x00\x00\x00\x00\x00\x00\x03" | \
+                       dd bs=42 count=1 conv=sync; \
+               hw_id="$(hw_id)"; \
+               echo -ne "\x$${hw_id:0:2}\x$${hw_id:2:2}\x$${hw_id:4:2}\x$${hw_id:6:2}" | \
+                       dd bs=20 count=1 conv=sync; \
+               echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+                       dd bs=8 count=1 conv=sync; \
+               echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+                       dd bs=58 count=1 conv=sync; \
+       ) > $(KDIR)/tmp/$(DEVICE_NAME).header
+       $(call Build/xor-image,-p $(xor_pattern) -x)
+       cat $(KDIR)/tmp/$(DEVICE_NAME).header $@ > $@.new
+       mv $@.new $@
+       rm -rf $(KDIR)/tmp/$(DEVICE_NAME).header
+endef
+
 define Build/umedia-header
        fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
 endef
index 320d4abd1f3e5c4a1fa7260298ab39ff20de742b..36898c99bc29d2431940a32ff2e8a2c377162445 100644 (file)
@@ -16,25 +16,6 @@ define Build/elecom-header
                -f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
 endef
 
-define Build/elx-header
-  $(eval hw_id=$(word 1,$(1)))
-  $(eval xor_pattern=$(word 2,$(1)))
-  ( \
-    echo -ne "\x00\x00\x00\x00\x00\x00\x00\x03" | \
-      dd bs=42 count=1 conv=sync; \
-    hw_id="$(hw_id)"; \
-    echo -ne "\x$${hw_id:0:2}\x$${hw_id:2:2}\x$${hw_id:4:2}\x$${hw_id:6:2}" | \
-      dd bs=20 count=1 conv=sync; \
-    echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
-      dd bs=8 count=1 conv=sync; \
-    echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
-      dd bs=58 count=1 conv=sync; \
-  ) > $(KDIR)/tmp/$(DEVICE_NAME).header
-  $(call Build/xor-image,-p $(xor_pattern) -x)
-  cat $(KDIR)/tmp/$(DEVICE_NAME).header $@ > $@.new
-  mv $@.new $@
-endef
-
 define Device/aigale_ai-br100
   MTK_SOC := mt7620a
   IMAGE_SIZE := 7936k
index 644f98419751a55717ee3b1825419a42071230dd..4cf9cf7ff23c53ef94aac9d5b1c65a5734de69b2 100644 (file)
@@ -30,25 +30,6 @@ define Build/elecom-wrc-factory
   mv $@.new $@
 endef
 
-define Build/elx-header
-  $(eval hw_id=$(word 1,$(1)))
-  $(eval xor_pattern=$(word 2,$(1)))
-  ( \
-    echo -ne "\x00\x00\x00\x00\x00\x00\x00\x03" | \
-      dd bs=42 count=1 conv=sync; \
-    hw_id="$(hw_id)"; \
-    echo -ne "\x$${hw_id:0:2}\x$${hw_id:2:2}\x$${hw_id:4:2}\x$${hw_id:6:2}" | \
-      dd bs=20 count=1 conv=sync; \
-    echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
-      dd bs=8 count=1 conv=sync; \
-    echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
-      dd bs=58 count=1 conv=sync; \
-  ) > $(KDIR)/tmp/$(DEVICE_NAME).header
-  $(call Build/xor-image,-p $(xor_pattern) -x)
-  cat $(KDIR)/tmp/$(DEVICE_NAME).header $@ > $@.new
-  mv $@.new $@
-endef
-
 define Build/iodata-factory
   $(eval fw_size=$(word 1,$(1)))
   $(eval fw_type=$(word 2,$(1)))