ath79: add support for UniFi AC-LR
authorAndreas Ziegler <dev@andreas-ziegler.de>
Sun, 6 Oct 2019 17:48:34 +0000 (19:48 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 15 Oct 2019 16:13:54 +0000 (18:13 +0200)
The Unifi AC-LR has identical hardware to the Unifi AC-Lite.
The antenna setup is different according to the vendor,
which explains the thicker enclosure.

Therefore, it is helpful to know the exact device variant,
instead of having "Ubiquiti UniFi-AC-LITE/LR".

Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de>
[fix legacy name in commit message; add old boardname to
SUPPORTED_DEVICES]
Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts [new file with mode: 0644]
target/linux/ath79/image/generic-ubnt.mk

index 0de17adb9d2317d38b8469c6fd1a128a862d140c..fe74bddbf1c988ad92700a427eb4ece7e7e6cf2f 100755 (executable)
@@ -50,6 +50,7 @@ ath79_setup_interfaces()
        ubnt,nanostation-ac-loco|\
        ubnt,rocket-m|\
        ubnt,unifiac-lite|\
+       ubnt,unifiac-lr|\
        ubnt,unifiac-mesh|\
        ubnt,unifi|\
        wd,mynet-wifi-rangeextender|\
index ebc1fc24d020ea946c0e589f5fead33a64c45a53..9d6b643a8ec0166381c9844e414af8fbb14f9288 100644 (file)
@@ -102,6 +102,7 @@ case "$FIRMWARE" in
                ath10kcal_patch_mac $(macaddr_add $(mtd_get_mac_binary info 0x8) +1)
                ;;
        ubnt,unifiac-lite|\
+       ubnt,unifiac-lr|\
        ubnt,unifiac-mesh|\
        ubnt,unifiac-mesh-pro|\
        ubnt,lap-120|\
index a3ae7089d5067b3d6bdd3a5cc52a41f55842c5fc..7b9fa0701b8f8f7c8588cabbecf1b85500ce2fe0 100644 (file)
@@ -5,5 +5,5 @@
 
 / {
        compatible = "ubnt,unifiac-lite", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-LITE/LR";
+       model = "Ubiquiti UniFi-AC-LITE";
 };
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts
new file mode 100644 (file)
index 0000000..a1e542a
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9563_ubnt_unifiac-lite.dtsi"
+
+/ {
+       compatible = "ubnt,unifiac-lr", "qca,qca9563";
+       model = "Ubiquiti UniFi-AC-LR";
+};
index 6ae766e2933138d2bec5c514dda3fc2003c4e229..984b18ccae5252f3baa67cfb6be6cc52b9b2c88b 100644 (file)
@@ -225,6 +225,13 @@ define Device/ubnt_unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-lite
 
+define Device/ubnt_unifiac-lr
+  $(Device/ubnt_unifiac)
+  DEVICE_MODEL := UniFi AC-LR
+  SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
+endef
+TARGET_DEVICES += ubnt_unifiac-lr
+
 define Device/ubnt_unifiac-mesh
   $(Device/ubnt_unifiac)
   DEVICE_MODEL := UniFi AC-Mesh