ath79: tidy up and fix IMAGE_SIZE for Ubiquiti devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 22 Oct 2019 11:08:23 +0000 (13:08 +0200)
committerJohn Crispin <john@phrozen.org>
Sun, 27 Oct 2019 13:02:27 +0000 (14:02 +0100)
This addresses IMAGE_SIZE inconsistencies in generic_ubnt.mk by:

1. (cosmetical) Move IMAGE_SIZE out of top definition ("ubnt"),
   since despite two all subdefinition have different values.
2. (change) Fix IMAGE_SIZE for ubnt-xm and ubnt-bz (7552k->7488k).
3. (cosmetical) Move IMAGE_SIZE of ubnt-wa devices to parent node
   since all have same size (it is defined in parent DTSI ...).

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/generic-ubnt.mk

index ddf9f55d111f1e658c8cee9c4a56216ab574f4e3..727025ba679f255655bf95728c4ab88cab102bf8 100644 (file)
@@ -36,7 +36,6 @@ endef
 define Device/ubnt
   DEVICE_VENDOR := Ubiquiti
   DEVICE_PACKAGES := kmod-usb2
-  IMAGE_SIZE := 7552k
   UBNT_BOARD := XM
   UBNT_VERSION := 6.0.0
   IMAGES += factory.bin
@@ -46,6 +45,7 @@ endef
 
 define Device/ubnt-bz
   $(Device/ubnt)
+  IMAGE_SIZE := 7448k
   UBNT_TYPE := BZ
   UBNT_CHIP := ar7240
   ATH_SOC := ar7241
@@ -53,6 +53,7 @@ endef
 
 define Device/ubnt-wa
   $(Device/ubnt)
+  IMAGE_SIZE := 15744k
   UBNT_TYPE := WA
   UBNT_CHIP := ar934x
   UBNT_BOARD := WA
@@ -64,6 +65,7 @@ define Device/ubnt-xm
   $(Device/ubnt)
   DEVICE_VARIANT := XM
   DEVICE_PACKAGES += kmod-usb-ohci rssileds
+  IMAGE_SIZE := 7448k
   UBNT_TYPE := XM
   UBNT_CHIP := ar7240
   ATH_SOC := ar7241
@@ -73,6 +75,7 @@ endef
 define Device/ubnt-xw
   $(Device/ubnt)
   DEVICE_VARIANT := XW
+  IMAGE_SIZE := 7552k
   UBNT_TYPE := XW
   UBNT_CHIP := ar934x
   UBNT_BOARD := XM
@@ -119,7 +122,6 @@ define Device/ubnt_lap-120
   DEVICE_MODEL := LiteAP ac
   DEVICE_VARIANT := LAP-120
   DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
-  IMAGE_SIZE := 15744k
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
 TARGET_DEVICES += ubnt_lap-120
@@ -128,7 +130,6 @@ define Device/ubnt_nanobeam-ac
   $(Device/ubnt-wa)
   DEVICE_MODEL := NanoBeam AC
   DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
-  IMAGE_SIZE := 15744k
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
 TARGET_DEVICES += ubnt_nanobeam-ac
@@ -137,7 +138,6 @@ define Device/ubnt_nanostation-ac
   $(Device/ubnt-wa)
   DEVICE_MODEL := Nanostation AC
   DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
-  IMAGE_SIZE := 15744k
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
 TARGET_DEVICES += ubnt_nanostation-ac
@@ -146,7 +146,6 @@ define Device/ubnt_nanostation-ac-loco
   $(Device/ubnt-wa)
   DEVICE_MODEL := Nanostation AC loco
   DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
-  IMAGE_SIZE := 15744k
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
 TARGET_DEVICES += ubnt_nanostation-ac-loco