ath79: add XM device variant for Ubiquiti devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 18 Sep 2019 19:36:46 +0000 (21:36 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 19 Sep 2019 21:43:27 +0000 (23:43 +0200)
So far, XW devices have DEVICE_VARIANT defined and XM devices have
no DEVICE_VARIANT set.

This adds DEVICE_VARIANT for XM devices, and moves definitions for
both XM and XW to the common definitions.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/generic-ubnt.mk

index 368da8e01beb5b7bbc5d02fb0a56af8e086a215f..2e2e75651481342ca3b93f251ea7a48a2808fb2f 100644 (file)
@@ -46,6 +46,7 @@ endef
 
 define Device/ubnt-xm
   $(Device/ubnt)
+  DEVICE_VARIANT := XM
   DEVICE_PACKAGES += kmod-usb-ohci rssileds
   UBNT_TYPE := XM
   UBNT_CHIP := ar7240
@@ -71,6 +72,7 @@ endef
 
 define Device/ubnt-xw
   $(Device/ubnt)
+  DEVICE_VARIANT := XW
   UBNT_TYPE := XW
   UBNT_CHIP := ar934x
   UBNT_BOARD := XM
@@ -96,7 +98,6 @@ TARGET_DEVICES += ubnt_bullet-m
 define Device/ubnt_bullet-m-xw
   $(Device/ubnt-xw)
   DEVICE_MODEL := Bullet-M
-  DEVICE_VARIANT := XW
   SUPPORTED_DEVICES += bullet-m-xw
 endef
 TARGET_DEVICES += ubnt_bullet-m-xw
@@ -118,7 +119,6 @@ TARGET_DEVICES += ubnt_nanostation-m
 define Device/ubnt_nanostation-m-xw
   $(Device/ubnt-xw)
   DEVICE_MODEL := Nanostation M
-  DEVICE_VARIANT := XW
   SUPPORTED_DEVICES += nano-m-xw
 endef
 TARGET_DEVICES += ubnt_nanostation-m-xw