ath79: add mikrotik subtarget
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>
Fri, 28 Feb 2020 15:01:02 +0000 (16:01 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 17 Mar 2020 10:50:47 +0000 (11:50 +0100)
This commit creates the ath79/mikrotik subtarget in order to support
MikroTik devices based on Qualcomm Atheros MIPS SoCs.

MikroTik devices need a couple of specific features: the split MiNOR
firmware MTD format, which is not used by other devices, and the 4k
sector erase size on SPI NOR storage, which can not be added to the
ath79/generic and ath79/nand subtargets now.

Additionally, the commit moves the two MikroTik devices already in
the generic and nand subtargets to this new one.

Tested on the RB922 board and the wAP AC router.

Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
26 files changed:
target/linux/ath79/Makefile
target/linux/ath79/base-files/lib/functions/mikrotik-caldata.sh [deleted file]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/generic/config-default
target/linux/ath79/generic/target.mk
target/linux/ath79/image/Makefile
target/linux/ath79/image/generic.mk
target/linux/ath79/image/mikrotik.mk [new file with mode: 0644]
target/linux/ath79/image/nand.mk
target/linux/ath79/mikrotik/base-files/etc/board.d/02_network [new file with mode: 0644]
target/linux/ath79/mikrotik/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom [new file with mode: 0644]
target/linux/ath79/mikrotik/base-files/etc/hotplug.d/firmware/11-ath10k-caldata [new file with mode: 0644]
target/linux/ath79/mikrotik/base-files/etc/uci-defaults/04_led_migration [new file with mode: 0644]
target/linux/ath79/mikrotik/base-files/lib/functions/mikrotik-caldata.sh [new file with mode: 0644]
target/linux/ath79/mikrotik/base-files/lib/upgrade/platform.sh [new file with mode: 0644]
target/linux/ath79/mikrotik/config-default [new file with mode: 0644]
target/linux/ath79/mikrotik/profiles/00-default.mk [new file with mode: 0644]
target/linux/ath79/mikrotik/target.mk [new file with mode: 0644]
target/linux/ath79/nand/base-files/etc/board.d/02_network
target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/nand/base-files/etc/uci-defaults/04_led_migration [deleted file]
target/linux/ath79/nand/base-files/lib/upgrade/platform.sh
target/linux/ath79/nand/config-default
target/linux/ath79/nand/target.mk

index e50ad2297b016807017841718b8c238922478162..9b203cf48e4f517fc05b975bdbdc710df910436b 100644 (file)
@@ -4,7 +4,7 @@ ARCH:=mips
 BOARD:=ath79
 BOARDNAME:=Atheros ATH79 (DTS)
 CPU_TYPE:=24kc
-SUBTARGETS:=generic nand tiny
+SUBTARGETS:=generic mikrotik nand tiny
 
 FEATURES:=ramdisk
 
diff --git a/target/linux/ath79/base-files/lib/functions/mikrotik-caldata.sh b/target/linux/ath79/base-files/lib/functions/mikrotik-caldata.sh
deleted file mode 100644 (file)
index 9c4016e..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright (C) 2019 Robert Marko <robimarko@gmail.com>
-# Copyright (C) 2019 Roger Pueyo Centelles <roger.pueyo@guifi.net>
-#
-# Helper function to extract MAC addresses and calibration data for MikroTik
-#
-
-mikrotik_caldata_extract() {
-       local part=$1
-       local offset=$(($2))
-       local count=$(($3))
-       local mtd
-       local erdfile="/lib/firmware/erd.bin"
-
-       mtd=$(find_mtd_chardev $part)
-       [ -n "$mtd" ] || caldata_die "no mtd device found for partition $part"
-
-       rbextract -e $mtd $erdfile
-
-       dd if=$erdfile of=/lib/firmware/$FIRMWARE iflag=skip_bytes bs=$count skip=$offset count=1 2>/dev/null || \
-               caldata_die "failed to extract calibration data from $mtd"
-}
index 168399d5669877943f277080ed5d07455e9e95de..6f9aed8bf575c92453576182d278ac1b28cc2390 100755 (executable)
@@ -21,7 +21,6 @@ ath79_setup_interfaces()
        dlink,dir-505|\
        engenius,ecb1750|\
        glinet,gl-ar300m-lite|\
-       mikrotik,routerboard-wap-g-5hact2hnd|\
        netgear,ex6400|\
        netgear,ex7300|\
        ocedo,koala|\
index b06a481c940e283271c875a97b8452ff606d2264..52a1502af445c0429f18b372430ea8665886509d 100644 (file)
@@ -3,7 +3,6 @@
 [ -e /lib/firmware/$FIRMWARE ] && exit 0
 
 . /lib/functions/caldata.sh
-. /lib/functions/mikrotik-caldata.sh
 
 board=$(board_name)
 
@@ -42,10 +41,6 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x1000 0x440
                ath9k_patch_mac $(mtd_get_mac_ascii u-boot-env ethaddr)
                ;;
-       mikrotik,routerboard-wap-g-5hact2hnd)
-               mikrotik_caldata_extract "art" 0x1000 0x440
-               ath9k_patch_mac $(macaddr_add $(mtd_get_mac_binary art 0x10) +2)
-               ;;
        nec,wg800hp)
                caldata_extract "art" 0x1000 0x440
                ath9k_patch_mac $(mtd_get_mac_text board_data 0x680)
index 2cab8c97545dffd035958625bbcdc95d81338ec5..ce8531d5ce001cc7c5246f32605165f167230d17 100644 (file)
@@ -4,7 +4,6 @@
 
 . /lib/functions/caldata.sh
 . /lib/functions/k2t.sh
-. /lib/functions/mikrotik-caldata.sh
 
 board=$(board_name)
 
@@ -66,9 +65,6 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary art 0x0) +2)
                ;;
-       mikrotik,routerboard-wap-g-5hact2hnd)
-               mikrotik_caldata_extract "art" 0x5000 0x844
-               ;;
        nec,wg800hp)
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(mtd_get_mac_text board_data 0x880)
index a15a1d897281a0cbbf82224b24461d0ce2f9e2e1..5459bafd7d5e3b03e5fc3ad81f10656c8f7aca62 100644 (file)
@@ -11,7 +11,6 @@ CONFIG_MICREL_PHY=y
 CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-3
 CONFIG_MTD_REDBOOT_PARTS=y
 CONFIG_MTD_SPLIT_EVA_FW=y
-CONFIG_MTD_SPLIT_MINOR_FW=y
 CONFIG_PHY_AR7100_USB=y
 CONFIG_PHY_AR7200_USB=y
 CONFIG_REGULATOR=y
index 488aa6df16554b08f25a0022829dd398570b74b7..88346efd2b09b492e85d87f3d5807970f5dc90d5 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=Generic
-FEATURES += minor squashfs
+FEATURES += squashfs
 
 DEFAULT_PACKAGES += wpad-basic
 
index c27db93947fe94edebb4b1047259995ee2318791..c568c7238cfa42f1d453917b48a675b1fc8d99ab 100644 (file)
@@ -73,6 +73,9 @@ include ./generic.mk
 include ./generic-tp-link.mk
 include ./generic-ubnt.mk
 endif
+ifeq ($(SUBTARGET),mikrotik)
+include ./mikrotik.mk
+endif
 ifeq ($(SUBTARGET),nand)
 include ./nand.mk
 endif
index 5a0b0ab67e11a264debaf5592b97096b2bb2e345..3ce51cc0d6e9a61be9182bd26263c3427d30d805 100644 (file)
@@ -1,5 +1,4 @@
 include ./common-buffalo.mk
-include ./common-mikrotik.mk
 include ./common-netgear.mk
 include ./common-tp-link.mk
 include ./common-yuncore.mk
@@ -765,19 +764,6 @@ define Device/librerouter_librerouter-v1
 endef
 TARGET_DEVICES += librerouter_librerouter-v1
 
-define Device/mikrotik_routerboard-wap-g-5hact2hnd
-  $(Device/mikrotik)
-  SOC := qca9556
-  DEVICE_MODEL := RouterBOARD wAP G-5HacT2HnD (wAP AC)
-  IMAGE_SIZE := 16256k
-  IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 -e | \
-       pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
-       append-metadata | check-size $$$$(IMAGE_SIZE)
-  DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
-  SUPPORTED_DEVICES += rb-wapg-5hact2hnd
-endef
-TARGET_DEVICES += mikrotik_routerboard-wap-g-5hact2hnd
-
 define Device/nec_wg1200cr
   SOC := qca9563
   DEVICE_VENDOR := NEC
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
new file mode 100644 (file)
index 0000000..a6863dc
--- /dev/null
@@ -0,0 +1,27 @@
+include ./common-mikrotik.mk
+
+define Device/mikrotik_routerboard-922uags-5hpacd
+  $(Device/mikrotik)
+  SOC := qca9558
+  DEVICE_MODEL := RouterBOARD 922UAGS-5HPacD
+  BOARD_NAME := routerboard
+  IMAGE/sysupgrade.bin = append-kernel | kernel2minor -s 2048 -e -c | \
+       sysupgrade-tar kernel=$$$$@ | append-metadata
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct \
+       kmod-usb2 nand-utils
+  SUPPORTED_DEVICES += rb-922uags-5hpacd
+endef
+TARGET_DEVICES += mikrotik_routerboard-922uags-5hpacd
+
+define Device/mikrotik_routerboard-wap-g-5hact2hnd
+  $(Device/mikrotik)
+  SOC := qca9556
+  DEVICE_MODEL := RouterBOARD wAP G-5HacT2HnD (wAP AC)
+  IMAGE_SIZE := 16256k
+  IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 -e | \
+       pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
+       append-metadata | check-size $$$$(IMAGE_SIZE)
+  DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
+  SUPPORTED_DEVICES += rb-wapg-5hact2hnd
+endef
+TARGET_DEVICES += mikrotik_routerboard-wap-g-5hact2hnd
index 4cb6ea295738965e0527957a7b7ac307bf015acb..8f28af46555c5b1540f8bd422eb239c5b46eb6e5 100644 (file)
@@ -1,4 +1,3 @@
-include ./common-mikrotik.mk
 include ./common-netgear.mk    # for netgear-uImage
 
 # attention: only zlib compression is allowed for the boot fs
@@ -129,19 +128,6 @@ define Device/glinet_gl-ar750s-nor
 endef
 TARGET_DEVICES += glinet_gl-ar750s-nor
 
-define Device/mikrotik_routerboard-922uags-5hpacd
-  $(Device/mikrotik)
-  SOC := qca9558
-  DEVICE_MODEL := RouterBOARD 922UAGS-5HPacD
-  BOARD_NAME := routerboard
-  IMAGE/sysupgrade.bin = append-kernel | kernel2minor -s 2048 -e -c | \
-       sysupgrade-tar kernel=$$$$@ | append-metadata
-  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct \
-       kmod-usb2 nand-utils
-  SUPPORTED_DEVICES += rb-922uags-5hpacd
-endef
-TARGET_DEVICES += mikrotik_routerboard-922uags-5hpacd
-
 # fake rootfs is mandatory, pad-offset 129 equals (2 * uimage_header + 0xff)
 define Device/netgear_ath79_nand
   DEVICE_VENDOR := NETGEAR
diff --git a/target/linux/ath79/mikrotik/base-files/etc/board.d/02_network b/target/linux/ath79/mikrotik/base-files/etc/board.d/02_network
new file mode 100644 (file)
index 0000000..ee795c7
--- /dev/null
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+. /lib/functions/system.sh
+. /lib/functions/uci-defaults.sh
+
+ath79_setup_interfaces()
+{
+       local board="$1"
+
+       case "$board" in
+       mikrotik,routerboard-922uags-5hpacd|\
+       mikrotik,routerboard-wap-g-5hact2hnd)
+               ucidef_set_interface_lan "eth0"
+               ;;
+       *)
+               ucidef_set_interfaces_lan_wan "eth0" "eth1"
+               ;;
+       esac
+}
+
+ath79_setup_macs()
+{
+       local board="$1"
+
+       case "$board" in
+       esac
+
+       [ -n "$lan_mac" ] && ucidef_set_interface_macaddr "lan" $lan_mac
+       [ -n "$wan_mac" ] && ucidef_set_interface_macaddr "wan" $wan_mac
+       [ -n "$label_mac" ] && ucidef_set_label_macaddr $label_mac
+}
+
+board_config_update
+board=$(board_name)
+ath79_setup_interfaces $board
+ath79_setup_macs $board
+board_config_flush
+
+exit 0
diff --git a/target/linux/ath79/mikrotik/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/mikrotik/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
new file mode 100644 (file)
index 0000000..f5f8848
--- /dev/null
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+[ -e /lib/firmware/$FIRMWARE ] && exit 0
+
+. /lib/functions/caldata.sh
+. /lib/functions/mikrotik-caldata.sh
+
+board=$(board_name)
+
+case "$FIRMWARE" in
+"ath9k-eeprom-ahb-18100000.wmac.bin")
+       case $board in
+       mikrotik,routerboard-wap-g-5hact2hnd)
+               mikrotik_caldata_extract "art" 0x1000 0x440
+               ath9k_patch_mac $(macaddr_add $(mtd_get_mac_binary art 0x10) +2)
+               ;;
+       *)
+               caldata_die "board $board is not supported yet"
+               ;;
+       esac
+       ;;
+esac
diff --git a/target/linux/ath79/mikrotik/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/mikrotik/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
new file mode 100644 (file)
index 0000000..6eb9a93
--- /dev/null
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+[ -e /lib/firmware/$FIRMWARE ] && exit 0
+
+. /lib/functions/caldata.sh
+. /lib/functions/mikrotik-caldata.sh
+
+board=$(board_name)
+
+case "$FIRMWARE" in
+"ath10k/cal-pci-0000:00:00.0.bin")
+       case $board in
+       mikrotik,routerboard-wap-g-5hact2hnd)
+               mikrotik_caldata_extract "art" 0x5000 0x844
+               ;;
+       esac
+       ;;
+"ath10k/cal-pci-0000:01:00.0.bin")
+       case $board in
+       mikrotik,routerboard-922uags-5hpacd)
+               mikrotik_caldata_extract "art" 0x5000 0x844
+               ;;
+       esac
+       ;;
+*)
+       exit 1
+       ;;
+esac
diff --git a/target/linux/ath79/mikrotik/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/mikrotik/base-files/etc/uci-defaults/04_led_migration
new file mode 100644 (file)
index 0000000..1a7b371
--- /dev/null
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+. /lib/functions.sh
+. /lib/functions/migrations.sh
+
+board=$(board_name)
+boardonly="${board##*,}"
+
+case "$board" in
+mikrotik,*)
+       migrate_leds "^rb:=mikrotik:"
+       ;;
+esac
+
+migrations_apply system
+
+exit 0
diff --git a/target/linux/ath79/mikrotik/base-files/lib/functions/mikrotik-caldata.sh b/target/linux/ath79/mikrotik/base-files/lib/functions/mikrotik-caldata.sh
new file mode 100644 (file)
index 0000000..9c4016e
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright (C) 2019 Robert Marko <robimarko@gmail.com>
+# Copyright (C) 2019 Roger Pueyo Centelles <roger.pueyo@guifi.net>
+#
+# Helper function to extract MAC addresses and calibration data for MikroTik
+#
+
+mikrotik_caldata_extract() {
+       local part=$1
+       local offset=$(($2))
+       local count=$(($3))
+       local mtd
+       local erdfile="/lib/firmware/erd.bin"
+
+       mtd=$(find_mtd_chardev $part)
+       [ -n "$mtd" ] || caldata_die "no mtd device found for partition $part"
+
+       rbextract -e $mtd $erdfile
+
+       dd if=$erdfile of=/lib/firmware/$FIRMWARE iflag=skip_bytes bs=$count skip=$offset count=1 2>/dev/null || \
+               caldata_die "failed to extract calibration data from $mtd"
+}
diff --git a/target/linux/ath79/mikrotik/base-files/lib/upgrade/platform.sh b/target/linux/ath79/mikrotik/base-files/lib/upgrade/platform.sh
new file mode 100644 (file)
index 0000000..a568689
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright (C) 2011 OpenWrt.org
+
+PART_NAME=firmware
+
+REQUIRE_IMAGE_METADATA=1
+platform_check_image() {
+       return 0
+}
+
+RAMFS_COPY_BIN='fw_printenv fw_setenv nandwrite'
+RAMFS_COPY_DATA='/etc/fw_env.config /var/lock/fw_printenv.lock'
+
+platform_do_upgrade_mikrotik_nand() {
+       CI_KERNPART=none
+       local fw_mtd=$(find_mtd_part kernel)
+       fw_mtd="${fw_mtd/block/}"
+       [ -n "$fw_mtd" ] || return
+       mtd erase kernel
+       tar xf "$1" sysupgrade-routerboard/kernel -O | nandwrite -o "$fw_mtd" -
+
+       nand_do_upgrade "$1"
+}
+
+platform_do_upgrade() {
+       local board=$(board_name)
+
+       case "$board" in
+       mikrotik,routerboard-922uags-5hpacd)
+               platform_do_upgrade_mikrotik_nand "$1"
+               ;;
+       *)
+               default_do_upgrade "$1"
+               ;;
+       esac
+}
diff --git a/target/linux/ath79/mikrotik/config-default b/target/linux/ath79/mikrotik/config-default
new file mode 100644 (file)
index 0000000..a95d134
--- /dev/null
@@ -0,0 +1,33 @@
+CONFIG_AT803X_PHY=y
+CONFIG_CRC16=y
+CONFIG_CRYPTO_DEFLATE=y
+CONFIG_GPIO_LATCH=y
+CONFIG_GPIO_WATCHDOG=y
+CONFIG_GPIO_WATCHDOG_ARCH_INITCALL=y
+CONFIG_LEDS_RESET=y
+CONFIG_LZO_DECOMPRESS=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_AR934X=y
+CONFIG_MTD_NAND_CORE=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_SPI_NAND=y
+CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=y
+CONFIG_MTD_SPLIT_MINOR_FW=y
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BLOCK=y
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+CONFIG_MTD_UBI_BEB_LIMIT=20
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_NET_SWITCHDEV=y
+CONFIG_PHY_AR7100_USB=y
+CONFIG_PHY_AR7200_USB=y
+CONFIG_REGULATOR=y
+CONFIG_REGULATOR_FIXED_VOLTAGE=y
+CONFIG_UBIFS_FS=y
+CONFIG_UBIFS_FS_ADVANCED_COMPR=y
+CONFIG_UBIFS_FS_LZO=y
+CONFIG_UBIFS_FS_ZLIB=y
+CONFIG_WATCHDOG_CORE=y
+CONFIG_ZLIB_DEFLATE=y
+CONFIG_ZLIB_INFLATE=y
diff --git a/target/linux/ath79/mikrotik/profiles/00-default.mk b/target/linux/ath79/mikrotik/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..14712da
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2020 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+       NAME:=Default Profile (all drivers)
+       PACKAGES:= \
+               kmod-usb-ohci kmod-usb2 nand-utils
+       PRIORITY := 1
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/mikrotik/target.mk b/target/linux/ath79/mikrotik/target.mk
new file mode 100644 (file)
index 0000000..face016
--- /dev/null
@@ -0,0 +1,9 @@
+BOARDNAME := MikroTik devices
+FEATURES += minor nand squashfs
+
+DEFAULT_PACKAGES += wpad-basic
+
+define Target/Description
+       Build firmware images for MikroTik devices based on Qualcomm Atheros
+       MIPS SoCs (AR71xx, AR72xx, AR91xx, AR93xx, QCA95xx).
+endef
index 06a2aec47189eeb224c4a6c2e511ee9e1a0e6705..1626ec31cacbc6196a1f65087eb1748fbf494616 100755 (executable)
@@ -8,8 +8,7 @@ ath79_setup_interfaces()
        local board="$1"
 
        case "$board" in
-       aerohive,hiveap-121|\
-       mikrotik,routerboard-922uags-5hpacd)
+       aerohive,hiveap-121)
                ucidef_set_interface_lan "eth0"
                ;;
        domywifi,dw33d)
index 8a1bed58c1bf3b657eda331b9e251e864bf33e37..d5fd3db24d6d14ca8f496a5d2502dbbaf9cfec6d 100644 (file)
@@ -3,7 +3,6 @@
 [ -e /lib/firmware/$FIRMWARE ] && exit 0
 
 . /lib/functions/caldata.sh
-. /lib/functions/mikrotik-caldata.sh
 
 board=$(board_name)
 
@@ -25,13 +24,6 @@ case "$FIRMWARE" in
                ;;
        esac
        ;;
-"ath10k/cal-pci-0000:01:00.0.bin")
-       case $board in
-       mikrotik,routerboard-922uags-5hpacd)
-               mikrotik_caldata_extract "art" 0x5000 0x844
-               ;;
-       esac
-       ;;
 *)
        exit 1
        ;;
diff --git a/target/linux/ath79/nand/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/nand/base-files/etc/uci-defaults/04_led_migration
deleted file mode 100644 (file)
index 1a7b371..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-. /lib/functions.sh
-. /lib/functions/migrations.sh
-
-board=$(board_name)
-boardonly="${board##*,}"
-
-case "$board" in
-mikrotik,*)
-       migrate_leds "^rb:=mikrotik:"
-       ;;
-esac
-
-migrations_apply system
-
-exit 0
index 8d6b639b40811b9037393280021634ce95fb11e6..ea77345b061d5bbe7512aaf7cbceb8e8974130c9 100644 (file)
@@ -10,24 +10,10 @@ platform_check_image() {
 RAMFS_COPY_BIN='fw_printenv fw_setenv nandwrite'
 RAMFS_COPY_DATA='/etc/fw_env.config /var/lock/fw_printenv.lock'
 
-platform_do_upgrade_mikrotik_nand() {
-       CI_KERNPART=none
-       local fw_mtd=$(find_mtd_part kernel)
-       fw_mtd="${fw_mtd/block/}"
-       [ -n "$fw_mtd" ] || return
-       mtd erase kernel
-       tar xf "$1" sysupgrade-routerboard/kernel -O | nandwrite -o "$fw_mtd" -
-
-       nand_do_upgrade "$1"
-}
-
 platform_do_upgrade() {
        local board=$(board_name)
 
        case "$board" in
-       mikrotik,routerboard-922uags-5hpacd)
-               platform_do_upgrade_mikrotik_nand "$1"
-               ;;
        glinet,gl-ar300m-nand|\
        glinet,gl-ar300m-nor)
                glinet_nand_nor_do_upgrade "$1"
index 52e12fa28124688c3bafbab8c3f17fc7f8e0cf6a..738f2f0a5ea6277e88f1590223bfddc1e874a023 100644 (file)
@@ -10,7 +10,6 @@ CONFIG_MTD_NAND_AR934X=y
 CONFIG_MTD_NAND_CORE=y
 CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_SPI_NAND=y
-CONFIG_MTD_SPLIT_MINOR_FW=y
 CONFIG_MTD_UBI=y
 CONFIG_MTD_UBI_BEB_LIMIT=20
 CONFIG_MTD_UBI_BLOCK=y
index fd5216b0ebf6c19d93962a9271ea89f945fd0b66..c565c9b2b8c45136ce7b04b8ea65fd55330cfc52 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME := Generic devices with NAND flash
 
-FEATURES += squashfs nand minor
+FEATURES += squashfs nand
 
 DEFAULT_PACKAGES += wpad-basic