ath79: add missing UBNT_REVISION
authorNick Hainke <vincent@systemli.org>
Sun, 26 Dec 2021 10:59:44 +0000 (11:59 +0100)
committerDavid Bauer <mail@david-bauer.net>
Mon, 27 Dec 2021 02:07:22 +0000 (03:07 +0100)
The UBNT_REVISION was already added for the ubnt-xw target because:

  U-boot bootloader on M-XW devices expects factory image revision
  version in specific format. On airOS v6.1.7 with `U-Boot 1.1.4-s1039
  (May 24 2017 - 15:58:18)` bootloader checks if the revision major(?)
  number is actually a number, but in currently generated images there's
  OpenWrt text and so the check fails

  ...

  By placing arbitrary correct number first in major version, we make the
  bootloader happy and we can flash factory images over TFTP again.

  commit d42a7c469909 ("ath79: ubnt-m-xw: Fix factory image flashing using TFTP recovery method")

Fixes errors in the form of (tftp flashing):
  sent DATA <block=8577, 412 bytes>
  received ERROR <code=2, msg=Firmware check failed>
  Error code 2: Firmware check failed

The missing UBNT_REVISION was not noticed before, since the
UBNT_REVISION field for the ubnt-xm target was also set to:
  "42.OpenWrt-..."
Probably, UBNT_REVISION for the ubnt-xm target was set by the ubnt-xw
and was never overridden somewhere else. However, it is missing and
should be part of the ubnt-xm device.

Signed-off-by: Nick Hainke <vincent@systemli.org>
target/linux/ath79/image/generic-ubnt.mk

index 3888e1652b9e6f9ec1c1e0cb4f332757f439cdd7..bb5eaa5458bc8af90dffac3fa28359cc957786d7 100644 (file)
@@ -103,6 +103,7 @@ define Device/ubnt-xm
   IMAGE_SIZE := 7448k
   UBNT_BOARD := XM
   UBNT_CHIP := ar7240
+  UBNT_REVISION := 42.$(UBNT_REVISION)
   UBNT_TYPE := XM
   UBNT_VERSION := 6.0.0
   KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma