ath79: fix SUPPORTED_DEVICES for ubnt_nanostation-m
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 4 Oct 2019 12:44:07 +0000 (14:44 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 21 Oct 2019 11:33:24 +0000 (13:33 +0200)
The ar71xx images for the Ubiquiti NanoStation M (XM) devices use
"nanostation-m" as board name, but the ath79 images are only
compatible with the "nano-m" board name, so sysupgrade complains.

By changing this additional supported device, sysupgrade smoothly
upgrades from ar71xx to ath79.

Ref: openwrt#2418

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/generic-ubnt.mk

index 801b0128ac7ba7cd6dafdb83181bd1d2511f46dd..ddf9f55d111f1e658c8cee9c4a56216ab574f4e3 100644 (file)
@@ -154,7 +154,7 @@ TARGET_DEVICES += ubnt_nanostation-ac-loco
 define Device/ubnt_nanostation-m
   $(Device/ubnt-xm)
   DEVICE_MODEL := Nanostation M
-  SUPPORTED_DEVICES += nano-m
+  SUPPORTED_DEVICES += nanostation-m
 endef
 TARGET_DEVICES += ubnt_nanostation-m