ar71xx/ath79: switch devices to the -ct driver and firmware
authorChristian Lamparter <chunkeey@gmail.com>
Mon, 17 Dec 2018 00:58:49 +0000 (01:58 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Mon, 17 Dec 2018 13:22:28 +0000 (14:22 +0100)
Since commit 61b5b4971e7 ("mac80211: make ath10k-ct the default ath10k")
select ath10k-ct and the -ct firmwares by default.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ar71xx/image/generic.mk
target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/generic.mk

index 18f0379845f9c0218b0e7b7943094de2f8811cf6..05428039d37bd40c8c16d6c58959d727b7067cf7 100644 (file)
@@ -898,7 +898,7 @@ TARGET_DEVICES += minibox-v1
 define Device/minibox-v3.2
   $(Device/tplink-16mlzma)
   DEVICE_TITLE := Gainstrong MiniBox V3.2
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca9887 -swconfig
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca9887-ct -swconfig
   BOARDNAME := MINIBOX-V3.2
   DEVICE_PROFILE := MINIBOXV32
   TPLINK_HWID := 0x3C00010C
index cb65aede5ef440146c779655ae095bfef8fa2faf..681c14dfb642e58428a88cc7bf5f984cc45d27df 100644 (file)
@@ -116,7 +116,7 @@ TARGET_DEVICES += ubnt_nano-m
 define Device/ubnt_lap-120
   $(Device/ubnt-wa)
   DEVICE_TITLE := Ubiquiti LiteAP ac (LAP-120)
-  DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 15744k
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
@@ -125,7 +125,7 @@ TARGET_DEVICES += ubnt_lap-120
 define Device/ubnt_nanostation-ac
   $(Device/ubnt-wa)
   DEVICE_TITLE := Ubiquiti Nanostation AC
-  DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 15744k
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
@@ -134,7 +134,7 @@ TARGET_DEVICES += ubnt_nanostation-ac
 define Device/ubnt_nanostation-ac-loco
   $(Device/ubnt-wa)
   DEVICE_TITLE := Ubiquiti Nanostation AC loco
-  DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 15744k
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
index cf71cb30b84690e3e5e5512659d9903720c82983..c8e1bcea4c5e6936a08c19c71b4a95affe3760f7 100644 (file)
@@ -212,7 +212,7 @@ TARGET_DEVICES += glinet_ar300m-nor
 define Device/glinet_gl-x750
   ATH_SOC := qca9531
   DEVICE_TITLE := GL.iNet GL-X750
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb2  kmod-ath10k ath10k-firmware-qca9887
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct
   IMAGE_SIZE := 16000k
 endef
 TARGET_DEVICES += glinet_gl-x750