iproute2: workaround compile issues with gcc 4.8.x
authorLuka Perkov <luka@openwrt.org>
Thu, 16 May 2013 00:04:48 +0000 (00:04 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 16 May 2013 00:04:48 +0000 (00:04 +0000)
SVN-Revision: 36642

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/000-warnings.patch [new file with mode: 0644]
package/network/utils/iproute2/patches/008-no_netem.patch
package/network/utils/iproute2/patches/110-extra-ccopts.patch

index 8e25f867b269798cf9b64c4d0f1858ce4047f5c3..ff80df4111955b2d1dfa2efc1cbd93d66ebf4b94 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=3.9.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
diff --git a/package/network/utils/iproute2/patches/000-warnings.patch b/package/network/utils/iproute2/patches/000-warnings.patch
new file mode 100644 (file)
index 0000000..8f07c38
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -30,8 +30,7 @@ CC = gcc
+ HOSTCC = gcc
+ DEFINES += -D_GNU_SOURCE
+ CCOPTS = -O2
+-WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
+-WFLAGS += -Wmissing-declarations -Wold-style-definition
++WFLAGS := -Wall -Wstrict-prototypes
+ CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
+ YACCFLAGS = -d -t -v
index 165ce0c9b9594f805372b13211bbfcc926db4cc5..78baeadbd153877fba5b2d100caf2532b0b0a09c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -36,7 +36,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
+@@ -35,7 +35,7 @@ WFLAGS := -Wall -Wstrict-prototypes
  CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
  YACCFLAGS = -d -t -v
  
index af38fe19894d1a1831fd5e434659e6990c998b40..71ec957ad0c83895e7dad774716f55e4ab82fbb6 100644 (file)
@@ -6,6 +6,6 @@
  DEFINES += -D_GNU_SOURCE
 -CCOPTS = -O2
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
- WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
- WFLAGS += -Wmissing-declarations -Wold-style-definition
+ WFLAGS := -Wall -Wstrict-prototypes
  
+ CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)