ramips: create R6220 dtsi and improve WNDR3700v5 support
authorJan Hoffmann <jan@3e8.eu>
Sun, 26 May 2019 13:01:09 +0000 (15:01 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 31 May 2019 09:21:22 +0000 (11:21 +0200)
The R6220 and WNDR3700v5 are identical apart from using NAND/NOR flash and
having a different casing. This adds a new cleaned up R6220.dtsi with the
common bits for both devices. Both devices now have feature parity.

Performed cleanup:
 * generic DTS node names
 * regulator for usb power
 * added missing pinctrl groups
 * use switch port instead of VLAN as trigger for WAN LED

Fixes for WNDR3700v5:
 * all LEDS work
 * correct ethernet MAC addresses

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/R6220.dts
target/linux/ramips/dts/R6220.dtsi [new file with mode: 0644]
target/linux/ramips/dts/WNDR3700V5.dts
target/linux/ramips/image/mt7621.mk

index 24234dfddddc723ed8b9bb26f36823608f245d62..1b02088ed24fda35b0f18f9b7985bd46cedc23b3 100755 (executable)
@@ -287,8 +287,9 @@ px-4885-8M)
        set_wifi_led "px-4885:orange:wifi"
        ;;
 r6220|\
-netgear,r6350)
-       ucidef_set_led_netdev "wan" "wan" "$boardname:green:wan" eth0.2
+netgear,r6350|\
+wndr3700v5)
+       ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x10"
        set_wifi_led "$boardname:green:wifi"
        ;;
 rakwireless,rak633)
index 9c9f2bef9c8d1e80dcfd842d3c6e635f618a34e6..aa0816c9cc24e9772fa3db1ac86286b3d47c2149 100755 (executable)
@@ -622,7 +622,8 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_binary factory 46)
                ;;
        r6220|\
-       netgear,r6350)
+       netgear,r6350|\
+       wndr3700v5)
                wan_mac=$(mtd_get_mac_binary factory 4)
                lan_mac=$(macaddr_add "$wan_mac" 1)
                ;;
index 335351c8259ea5261131ac29c32b35438cdc9292..28c3a3938dd0553fa260f5408f07580016fda305 100644 (file)
@@ -1,6 +1,7 @@
+// SPDX-License-Identifier: GPL-2.0
 /dts-v1/;
 
-#include "mt7621.dtsi"
+#include "R6220.dtsi"
 
 #include <dt-bindings/gpio/gpio.h>
 #include <dt-bindings/input/input.h>
@@ -8,87 +9,26 @@
 / {
        compatible = "netgear,r6220", "mediatek,mt7621-soc";
        model = "Netgear R6220";
+};
 
-       aliases {
-               led-boot = &led_power;
-               led-failsafe = &led_power;
-               led-running = &led_power;
-               led-upgrade = &led_power;
-       };
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x8000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_power: power {
-                       label = "r6220:green:power";
-                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
-               };
-
-               usb {
-                       label = "r6220:green:usb";
-                       gpios = <&gpio0 15 GPIO_ACTIVE_LOW>;
-                       trigger-sources = <&xhci_ehci_port1>, <&ehci_port2>;
-                       linux,default-trigger = "usbport";
-               };
-
-               internet {
-                       label = "r6220:green:wan";
-                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
-               };
-
-               wifi {
-                       label = "r6220:green:wifi";
-                       gpios = <&gpio0 16 GPIO_ACTIVE_LOW>;
-               };
-
-               wps {
-                       label = "r6220:green:wps";
-                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               poll-interval = <20>;
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
+&led_power {
+       label = "r6220:green:power";
+};
 
-               wifi {
-                       label = "wifi";
-                       gpios = <&gpio0 8 GPIO_ACTIVE_HIGH>;
-                       linux,code = <KEY_RFKILL>;
-               };
+&led_usb {
+       label = "r6220:green:usb";
+};
 
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
+&led_internet {
+       label = "r6220:green:wan";
+};
 
-       gpio_export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
+&led_wifi {
+       label = "r6220:green:wifi";
+};
 
-               usbpower {
-                       gpio-export,name = "usbpower";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio0 10 GPIO_ACTIVE_HIGH>;
-               };
-       };
+&led_wps {
+       label = "r6220:green:wps";
 };
 
 &nand {
                };
        };
 };
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       mt76@0,0 {
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&pcie1 {
-       mt76@0,0 {
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0000>;
-               ieee80211-freq-limit = <2400000 2500000>;
-       };
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0x00000004>;
-};
-
-&pinctrl {
-       state_default: pinctrl0 {
-               gpio {
-                       ralink,group = "uart3", "jtag";
-                       ralink,function = "gpio";
-               };
-       };
-};
diff --git a/target/linux/ramips/dts/R6220.dtsi b/target/linux/ramips/dts/R6220.dtsi
new file mode 100644 (file)
index 0000000..98a2078
--- /dev/null
@@ -0,0 +1,124 @@
+// SPDX-License-Identifier: GPL-2.0
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "mediatek,mt7621-soc";
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x8000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+               };
+
+               led_usb: usb {
+                       gpios = <&gpio0 15 GPIO_ACTIVE_LOW>;
+                       trigger-sources = <&xhci_ehci_port1>, <&ehci_port2>;
+                       linux,default-trigger = "usbport";
+               };
+
+               led_internet: internet {
+                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+               };
+
+               led_wifi: wifi {
+                       gpios = <&gpio0 16 GPIO_ACTIVE_LOW>;
+               };
+
+               led_wps: wps {
+                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               wifi {
+                       label = "wifi";
+                       gpios = <&gpio0 8 GPIO_ACTIVE_HIGH>;
+                       linux,code = <KEY_RFKILL>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       reg_usb_vbus: regulator {
+               compatible = "regulator-fixed";
+               regulator-name = "usb_vbus";
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               gpio = <&gpio0 10 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+       };
+};
+
+&xhci {
+       vbus-supply = <&reg_usb_vbus>;
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "pci14c3,7662";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "pci14c3,7603";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x00000004>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "uart3", "uart2", "jtag", "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
index 4ef0d70f180b107b24020c7d847c95dbfcfa792e..475ddb7e959f43eef35b1a430245d93d174a236a 100644 (file)
@@ -1,6 +1,7 @@
+// SPDX-License-Identifier: GPL-2.0
 /dts-v1/;
 
-#include "mt7621.dtsi"
+#include "R6220.dtsi"
 
 #include <dt-bindings/gpio/gpio.h>
 #include <dt-bindings/input/input.h>
@@ -8,76 +9,32 @@
 / {
        compatible = "netgear,wndr3700-v5", "mediatek,mt7621-soc";
        model = "Netgear WNDR3700v5";
+};
 
-       aliases {
-               led-boot = &led_power;
-               led-failsafe = &led_power;
-               led-running = &led_power;
-               led-upgrade = &led_power;
-       };
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x8000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600 maxcpus=2";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               wps {
-                       label = "wndr3700v5:green:wps";
-                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
-               };
-
-               led_power: power {
-                       label = "wndr3700v5:green:power";
-                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               poll-interval = <20>;
-
-               wps {
-                       label = "wndr3700v5:wps";
-                       gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
+&led_power {
+       label = "wndr3700v5:green:power";
+};
 
-               wifi {
-                       label = "wndr3700v5:wifi";
-                       gpios = <&gpio0 8 GPIO_ACTIVE_HIGH>;
-                       linux,code = <KEY_RFKILL>;
-               };
+&led_usb {
+       label = "wndr3700v5:green:usb";
+};
 
-               reset {
-                       label = "wndr3700v5:reset";
-                       gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
+&led_internet {
+       label = "wndr3700v5:green:wan";
+};
 
-       gpio_export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
+&led_wifi {
+       label = "wndr3700v5:green:wifi";
+};
 
-               usbpower {
-                       gpio-export,name = "usbpower";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio0 10 GPIO_ACTIVE_HIGH>;
-               };
-       };
+&led_wps {
+       label = "wndr3700v5:green:wps";
 };
 
 &spi0 {
        status = "okay";
 
-       mx25l12805d@0 {
+       flash@0 {
                compatible = "jedec,spi-nor";
                reg = <0>;
                spi-max-frequency = <10000000>;
                };
        };
 };
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       mt76@0,0 {
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&pcie1 {
-       mt76@0,0 {
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0000>;
-       };
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0x0000000c>;
-};
-
-&pinctrl {
-       state_default: pinctrl0 {
-               gpio {
-                       ralink,group = "rgmii2", "mdio", "wdt";
-                       ralink,function = "gpio";
-               };
-       };
-};
index c21b9b4b63adf4ee44b3b983439d2ccb5b33cad3..2eb7feb5bffd2360007b12ffcf965399b371c144 100644 (file)
@@ -550,7 +550,8 @@ define Device/wndr3700v5
   IMAGE/factory.img := pad-extra 320k | $$(IMAGE/default) | pad-to $$$$(BLOCKSIZE) | \
        sercom-footer | pad-to 128 | zip WNDR3700v5.bin | sercom-seal
   DEVICE_TITLE := Netgear WNDR3700v5
-  DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 wpad-basic
+  DEVICE_PACKAGES := \
+       kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
 endef
 TARGET_DEVICES += wndr3700v5