ramips: mt7621: merge two variants of MQmaker WiTi together
authorChuanhong Guo <gch981213@gmail.com>
Wed, 10 Jul 2019 15:57:36 +0000 (23:57 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Thu, 11 Jul 2019 14:11:21 +0000 (22:11 +0800)
Since we can auto-detect memory now, we don't need 2 dts for two
memory variants.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/mt7621_mqmaker_witi-256m.dts [deleted file]
target/linux/ramips/dts/mt7621_mqmaker_witi-512m.dts [deleted file]
target/linux/ramips/dts/mt7621_mqmaker_witi.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_mqmaker_witi.dtsi [deleted file]
target/linux/ramips/image/mt7621.mk

index 090749e1baa110e1f0a424b6e023cddb1168ee44..688ce555706260182a03d1cbe9570e9589a2567d 100755 (executable)
@@ -63,8 +63,7 @@ ramips_setup_interfaces()
        mediatek,mt7621-eval-board|\
        mediatek,mt7628an-eval-board|\
        mercury,mac1200r-v2|\
-       mqmaker,witi-256m|\
-       mqmaker,witi-512m|\
+       mqmaker,witi|\
        mtc,wr1201|\
        netgear,r6220|\
        netgear,r6350|\
diff --git a/target/linux/ramips/dts/mt7621_mqmaker_witi-256m.dts b/target/linux/ramips/dts/mt7621_mqmaker_witi-256m.dts
deleted file mode 100644 (file)
index 7d08368..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-/dts-v1/;
-
-#include "mt7621_mqmaker_witi.dtsi"
-
-/ {
-       compatible = "mqmaker,witi-256m", "mqmaker,witi", "mediatek,mt7621-soc";
-       model = "MQmaker WiTi (256MB RAM)";
-};
diff --git a/target/linux/ramips/dts/mt7621_mqmaker_witi-512m.dts b/target/linux/ramips/dts/mt7621_mqmaker_witi-512m.dts
deleted file mode 100644 (file)
index 5391c32..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-/dts-v1/;
-
-#include "mt7621_mqmaker_witi.dtsi"
-
-/ {
-       compatible = "mqmaker,witi-512m", "mqmaker,witi", "mediatek,mt7621-soc";
-       model = "MQmaker WiTi (512MB RAM)";
-};
diff --git a/target/linux/ramips/dts/mt7621_mqmaker_witi.dts b/target/linux/ramips/dts/mt7621_mqmaker_witi.dts
new file mode 100644 (file)
index 0000000..803b35f
--- /dev/null
@@ -0,0 +1,116 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "mqmaker,witi", "mediatek,mt7621-soc";
+       model = "MQmaker WiTi";
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       palmbus: palmbus@1E000000 {
+               i2c@900 {
+                       status = "okay";
+
+                       pcf8563: rtc@51 {
+                               status = "okay";
+                               compatible = "nxp,pcf8563";
+                               reg = <0x51>;
+                       };
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0xfb0000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       mt76@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+               mtd-mac-address = <&factory 0xe000>;
+       };
+};
+
+&pcie1 {
+       mt76@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+               mtd-mac-address = <&factory 0xe000>;
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "wdt", "rgmii2", "jtag", "mdio";
+                       ralink,function = "gpio";
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/mt7621_mqmaker_witi.dtsi b/target/linux/ramips/dts/mt7621_mqmaker_witi.dtsi
deleted file mode 100644 (file)
index 6e474e9..0000000
+++ /dev/null
@@ -1,115 +0,0 @@
-/dts-v1/;
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "mqmaker,witi", "mediatek,mt7621-soc";
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       palmbus: palmbus@1E000000 {
-               i2c@900 {
-                       status = "okay";
-
-                       pcf8563: rtc@51 {
-                               status = "okay";
-                               compatible = "nxp,pcf8563";
-                               reg = <0x51>;
-                       };
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-};
-
-&sdhci {
-       status = "okay";
-};
-
-&spi0 {
-       status = "okay";
-
-       m25p80@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <10000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x10000>;
-                               read-only;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x50000 0xfb0000>;
-                       };
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       mt76@0,0 {
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-               mtd-mac-address = <&factory 0xe000>;
-       };
-};
-
-&pcie1 {
-       mt76@0,0 {
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0000>;
-               ieee80211-freq-limit = <2400000 2500000>;
-               mtd-mac-address = <&factory 0xe000>;
-       };
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0xe000>;
-};
-
-&pinctrl {
-       state_default: pinctrl0 {
-               gpio {
-                       ralink,group = "wdt", "rgmii2", "jtag", "mdio";
-                       ralink,function = "gpio";
-               };
-       };
-};
index 1b3b132b36961adaa21fea2c0ce2036d0943ce19..1cd9092b141ee3f6d2a0f973b24797438374fe2b 100644 (file)
@@ -344,30 +344,17 @@ define Device/mikrotik_rbm33g
 endef
 TARGET_DEVICES += mikrotik_rbm33g
 
-define Device/mqmaker_witi-256m
+define Device/mqmaker_witi
   MTK_SOC := mt7621
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
   DEVICE_VENDOR := MQmaker
   DEVICE_MODEL := WiTi
-  DEVICE_VARIANT := 256MB RAM
   DEVICE_PACKAGES := \
        kmod-ata-core kmod-ata-ahci kmod-mt76x2 kmod-sdhci-mt7620 kmod-usb3 \
        kmod-usb-ledtrig-usbport wpad-basic
-  SUPPORTED_DEVICES += witi
+  SUPPORTED_DEVICES += witi mqmaker,witi-256m mqmaker,witi-512m
 endef
-TARGET_DEVICES += mqmaker_witi-256m
-
-define Device/mqmaker_witi-512m
-  MTK_SOC := mt7621
-  IMAGE_SIZE := $(ralink_default_fw_size_16M)
-  DEVICE_VENDOR := MQmaker
-  DEVICE_MODEL := WiTi
-  DEVICE_VARIANT := 512MB RAM
-  DEVICE_PACKAGES := \
-       kmod-ata-core kmod-ata-ahci kmod-mt76x2 kmod-sdhci-mt7620 kmod-usb3 \
-       kmod-usb-ledtrig-usbport wpad-basic
-endef
-TARGET_DEVICES += mqmaker_witi-512m
+TARGET_DEVICES += mqmaker_witi
 
 define Device/mtc_wr1201
   MTK_SOC := mt7621