pppd: fix build with musl
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2014 22:26:08 +0000 (22:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Jun 2014 22:26:08 +0000 (22:26 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 41404

package/network/services/ppp/Makefile

index e4e3014f5e1b9afbe906d1d1a89cc43b1cec21f6..4cee97a0a2d5c01e2f8799cdd7a25de2a6ef781e 100644 (file)
@@ -171,6 +171,9 @@ else
   MAKE_FLAGS += HAVE_MULTILINK=
 endif
 
+ifdef CONFIG_USE_MUSL
+  MAKE_FLAGS += USE_LIBUTIL=
+endif
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include